Can't quote posts that start with "I"


  • Banned

    Continuing the discussion from Discourse and our reaction to it:

    @Lorne_Kates said:

    Stop making posts that start with "I". Your product can't quote those.

    I can quote posts that start with I? What's the issue exactly?

    I grab text by holding down the mouse button on the far right, then move the mouse from right to left and release the mouse button in the left gutter. It's a sweeping motion from right-to-left, like so:

    The sparkle marks are click and release points. When I complete the motion I get a quote reply button I click on:

    Is there something I am missing?



  • @codinghorror said:

    I can quote posts that start with I? What's the issue exactly?

    Must be something about the particular gutter tolerances? Enough of us have experienced the bug that it must be something "out of the ordinary".



  • Select to just before the "I", it works, just lacking the "I".

    Drag your selection left of the "I" and you select a whole bunch of random stuff and lose the "Quote Reply" button. I started in exactly the same place, and stopped just left of the "I". (I really wish Printscreen would grab the mouse cursor...)



  • @codinghorror said:

    Is there something I am missing?

    Browser behaviour?

    In firefox, your playful and childlike instructions do not work.



  • Okay I just video'd the issue. However I had to do it the Swampy Way™ and shoot the video with my cell phone camera because fraps doesn't freaking record web browsers!!! 😡

    https://www.youtube.com/watch?v=GNocWUqI9J0



  • @codinghorror said:

    Is there something I am missing?

    Worthwhile support for mobile devices? I have a freaking stylus and it's still hard as hell to quote stuff on the phone.



  • @moderator said:

    I have a freaking stylus

    I thought you finally upgraded from the Newton..



  • @moderator said:

    I have a freaking stylus

    I have a normal one. Get yours checked out.



  • I prefer having a stylus, for the unsurpassed pointing precision. Fine-grain precision turns women on.



  • I can quote lines that start with "I" just fine--Chrome on Linux.

    Have you guys who can't tried selecting from the end of the text to the beginning? That's become my default mode of selecting text because the browser lets you select any part of the line after the last character and it just starts highlighting from the last character. Trying to select a first character is a PITA because it's too easy to overshoot or undershoot.

    BTW, that's true for me for all sites, including Community Server.



  • @morbiuswilters said:

    Have you guys who can't tried selecting from the end of the text to the beginning?

    Yes. It either stops before the I, or it jumps past the I-- either deselecting what you have, or selecting the "meta" line (username, time posted, etc), which disables the Quote floater. Or it does both.

    mott555 posted a video with the problem in the Bug thread. I would post a link directly to that post, but I don't see any element I can right-click copy link. His username goes to his preference page. The time (sorry, the stupid "minutes ago" shit) is the url appended with a #, but not #post_id. Share a link just pops up stupid Social widgets. So if you want to see the video, just go to the bugs thread, and scroll down-- well, I would say "halfway down the thread", but I'll change that to "I have no fucking idea".

    NOTE: I'm sure a DIscourse fanboi will reply to this with some non-intuitive convoluted way of linking to that post that's SO MUCH BETTER than having a permilink on each post. SO MUCH BETTER.



  • Double posting because I don't know if my above post is real or not. I posted it, it shows there, but half the reply is still in this reply box or if it went live. If I click Cancel, it says it will abandon my post, and I don't know if that means what I see on the screen is a live preview, or live. So here's my first double post because DISCOVERABLE:
    Yes. It either stops before the I, or it jumps past the I-- either deselecting what you have, or selecting the "meta" line (username, time posted, etc), which disables the Quote floater. Or it does both.

    mott555 posted a video with the problem in the Bug thread. I would post a link directly to that post, but I don't see any element I can right-click copy link. His username goes to his preference page. The time (sorry, the stupid "minutes ago" shit) is the url appended with a #, but not #post_id. Share a link just pops up stupid Social widgets. So if you want to see the video, just go to the bugs thread, and scroll down-- well, I would say "halfway down the thread", but I'll change that to "I have no fucking idea".

    NOTE: I'm sure a DIscourse fanboi will reply to this with some non-intuitive convoluted way of linking to that post that's SO MUCH BETTER than having a permilink on each post. SO MUCH BETTER.



  • @morbiuswilters said:

    Have you guys who can't tried selecting from the end of the text to the beginning?

    Yes. It either stops before the I, or it jumps past the I-- either deselecting what you have, or selecting the "meta" line (username, time posted, etc), which disables the Quote floater. Or it does both.

    And the half-reply is STILL HERE! I'll just it, hopefully third time is a charm.


  • Banned

    Option #1

    Option #2



  • @morbiuswilters said:

    Have you guys who can't tried selecting from the end of the text to the beginning?

    Yes. It either stops before the I, or it jumps past the I-- either deselecting what you have, or selecting the "meta" line (username, time posted, etc), which disables the Quote floater. Or it does both.

    Nope, I hit reply, and the half-post is still there. So

    Bug: Reply box contains a half-completed post, even though that post was completed.
    Expectation: After i reply, the draft should be purged.
    Solution: Fuck if I know, it's your software, you fix it.



  • @Lorne_Kates said:

    NOTE: I'm sure a DIscourse fanboi will reply to this with some non-intuitive convoluted way of linking to that post that's SO MUCH BETTER than having a permilink on each post. SO MUCH BETTER.

    Actually, the posts are permalink-able. Kinda.

    See, as you scroll down the URL bar of your browser is changing. So scroll down to where the post you want to link is the top of your browser and grab the URL from your URL bar. Like so:

    http://what.thedailywtf.com/t/cant-quote-posts-that-start-with-i/355/11

    Caveats:
    -When you follow that link, as the page is loading it won't always "stay" at that post. As things load the URL actually might change (in the case of the above link, to post 10 or 12..)

    • If someone replies while you are trying to get the URL, the page will jump around like a cracked-out monkey and you will lose your place. That just happened to me.

    Edit: Or just click the goddamn permanlink icon, like Sam did. Fuck, I knew that was there.

    My first caveat still applies.



  • @morbiuswilters said:

    -When you follow that link, as the page is loading it won't always "stay" at that post. As things load the URL actually might change (in the case of the above link, to post 10 or 12..)

    For example, I just clicked that link I posted to your post #11 and it took me to post 10 and updated the URL bar to post 10. *shrug*



  • @sam said:

    Option #1

    Doesn't work. My URL bar reads: http://what.thedailywtf.com/t/since-this-is-a-beta-i-guess-lets-do-some-genuinely-useful-bug-reports/296/148#

    And no, I'm not using IE9.

    @sam said:

    Option #2

    So yup, convoluted overthought solution. Instead of EVERY FORUM'S method of "right click permalink, which means i can also see the entire hyperlink in the status bar", i instead have to do "hope to notice a light grey icon against a white background, hover over it to be told it's a social media widget, click on it and see that most everything is social media related so gut reaction is it's something I don't want.. and then notice that there is indeed a hyperlink in a tiny textbox, but I can't see the entire hyperlink so I don't know if it is or isn't, so I'll have to copy and paste it somewhere else to find out first".

    Also, what is up with the rounded icons looking non-rounded? Not limited to Disocurse, this is every "everything is a tablet" piece of software. Is it not possible to draw a circle on a tablet without it looking like it was hand-done in MSPaint, printed out, put on a wooden table, re-drawn by hand with crayon, then put back into the computer by taking a photo of it with a toy JamCam from 1999?"


  • Banned

    @Lorne_Kates said:

    Doesn't work.

    A bug we will fix. I need a proper repro though, noticed it happened earlier for me, a full refresh of the page made it go away.

    Are you saying you want the word permalink on every post?



  • @sam said:

    A bug we will fix. I need a proper repro though, noticed it happened earlier for me, a full refresh of the page made it go away.

    No clue. If I notice repro steps, I'll post them.

    @sam said:

    Are you saying you want the word permalink on every post?

    It is the most discoverable and is a well known and recognized term, though a bit kludgy. Having SOME element that is a permalink for right-clicking on (or middle clicking to open in new tab to work with later). Heck, make the share icon thing it-- keep the existing popup functionality, but instead of being a div with onclick, wrap it in a hyperlink to the permalink. onclick will still do return(false) so it shouldn't effect clicking on it.


  • Banned

    You can talk to @riking about that. He submitted a patch to Discourse so permalinks, when clicked on, show up in the top quarter of the page, rather than the top. This leads to the disconnect, because the URL reflects the post that is at the top of the page, not the post that is in the middle or top quadrant.


  • Banned

    @Lorne_Kates said:

    Having SOME element that is a permalink for right-clicking on

    The date at top right of the post works like this, ala Twitter. @sam neglected to mention the third way to get a link to a post, its timestamp.


  • Banned

    Not fair, I was just about to type that 🙂



  • @codinghorror said:

    @sam neglected to mention the third way to get a link to a post, its timestamp.

    Okay, but it's bullshit if there aren't at least four ways to get it. What kind of crap software are you running here?



  • @codinghorror said:

    The date at top right of the post works like this, ala Twitter

    Not when I hover over it. Let's see. Right click, and the magic eight ball says:
    http://what.thedailywtf.com/t/cant-quote-posts-that-start-with-i/355/21#

    So a "sometimes work"



  • dafuq? I post a permalink and it replaces it with the text of the post? No.

    Alternatively: Hey, forum users-- there's a way to feed input into an algorithm that gets processed in the backend and produces unknown output! Who can break it first?



  • This is a test. Trying to repro a bug. Ignore unless I followed up on.

    Trying to repro bug where a half-posted reply gets stuck in the reply box. Encountered it three times. Don't know how to repro.



  • @morbiuswilters said:

    I can quote lines that start with "I" just fine--Chrome on Linux.

    Chrome 34 on Win7. No repro here, either. I can even start dragging at the left, and it works fine if I'm careful.



  • @Lorne_Kates said:

    dafuq? I post a permalink and it replaces it with the text of the post? No.

    That's the "one box" functionality. If you post a URL on a line by itself, the content is included (only works for certain sites, like Wikipedia or Github).

    You can bypass by adding a space before the URL or by creating a normal a href link, or by using the link icon in the reply box.



  • @morbiuswilters said:

    That's the "one box" functionality. If you post a URL on a line by itself, the content is included

    What the? Where's my onebox?

    @morbiuswilters said:

    (only works for certain sites, like Wikipedia or Github).

    Awww... you guys are no fun.


  • Banned

    Use try.discourse.org for testing in a sandbox, not a live forum, please.



  • @codinghorror said:

    Use try.discourse.org for testing in a sandbox, not a live forum, please.

    Wait, now this is a live broken forum instead of a beta broken forum?

    And did you ever even once visit the existing forum? 57.4% of all posts there were attempts to break the forum software. There's even an entire thread dedicated to doing just that. Part of the reason CS is being replaced is because it was so breakable. And when CS's replacement was announced, one of the things we explicitly said we'd try to do is break the shit out of it to see if it's worse than CS.

    So if something gets broken, or someone tries to break it, that's expected behavior. If the forum can't survive a < 1 day beta(?) test, it shouldn't go live.

    And for the record, "onebox" is one of the things I personally have explicit concerns about. I raised the issue in previous forum discussions on Discourse. It looks, feels and acts like a massive security hole just waiting to happen. DDOS. Mass shock-image posting. Infinite redirects. I want to know how bad it is.



  • @Lorne_Kates said:

    57.4% of all posts there were attempts to break the forum software. There's even an entire thread dedicated to doing just that.

    Really? How come I never found that. Either it's tucked away somewhere inconspicuous, or nobody's posted to in a long time, because I thought I had read every thread that had activity in, like, the last year.



  • I assumed it was deleted. It's been a long time since I visited it (> 1 year) and last I knew it was totally unreadable, there were bright colors, the layout might as well have been a random sprinkling of HTML elements, and there was also a logout bomb on there that caused you to insta-logout if you opened the thread.

    Filed Under: Community Server: The new LSD



  • @Lorne_Kates said:

    DDOS. Mass shock-image posting. Infinite redirects. I want to know how bad it is.

    Oneboxes only work on a list of whitelisted sites.

    So you'd have to find/create a shock image on one of those sites (which are all generally moderated), and then post it here (which is also moderated). Seems safer than any generic image embeds that happen anywhere else.


  • :belt_onion:

    @Lorne_Kates said:

    And for the record, "onebox" is one of the things I personally have explicit concerns about. I raised the issue in previous forum discussions on Discourse. It looks, feels and acts like a massive security hole just waiting to happen. DDOS. Mass shock-image posting. Infinite redirects. I want to know how bad it is.

    Reverse Heartbleed. (A real thing, though I imagine most of the Web sites in the "onebox" white list have now been inoculated against it. Still amusing.)


  • :belt_onion:

    @awesomerobot said:

    So you'd have to find/create a shock image on one of those sites (which are all generally moderated), and then post it here (which is also moderated). Seems safer than any generic image embeds that happen anywhere else.

    Wikipedia doesn't seem safe to me. Most vandalism is literally reverted within a minute, there are even bots that can handle vandalism with a very high success rate, yet somehow as an admin I still found a Tubgirl upload that'd survived since 2006. 😨

    @morbiuswilters said:

    http://en.wikipedia.org/wiki/Kitten

    On the other hand: G'AWWW.

    Filed under: JESUS CHRIST, Discourse, now why when I click the link to get to the topic listing does focus change away from my Web browser to a completely different window? How do you even DO that? What the fuck are you doing to my browser?! Someone teach me how to do tags; in order to emulate CS commas have to break them though



  • Right, but I could just upload the tubgirl image directly right here in this post anyway. I could even hide it behind a link.


  • :belt_onion:

    What in God's name possessed me to click that link in your post?! Thank God you didn't actually make it functional. 😑

    Filed under: WHY IS THERE A LOADING INDICATOR PERMANENTLY STUCK ON THIS PAGE



  • I breifly considered it because I knew people would click it. 🙈



  • @heterodox said:

    On the other hand: G'AWWW.

    Hey, why do quote blocks -- literally text from this website which was included in a post for context -- start out collapsed, but onebox doesn't? Hell, that gigantic Wikipedia block can't even be collapsed at all. I don't agree with that.

    Bug: Onebox blocks are gigantic eyesores that cannot be collapsed.
    Expected: Oneboxes should start collapsed (or at least semi-collapsed, like Twitter posts with images), and then we should be able to open and close them.
    Actual: Unstoppable nightmare fuel:



  • @heterodox said:

    What in God's name possessed me to click that link in your post?!

    Once again, Chrome has decided to stop showing me link URL's before I click them, so I ain't clickin' nothin' even remotely suspect until it's behavin' itself agin. (I don't think this has anything to do with Discourse; it's misbehaving in other tabs in this window, but other windows are OK.)



  • @moderator said:

    why do quote blocks -- literally text from this website which was included in a post for context -- start out collapsed

    They do? Not for me.

    Edit: Nevermind. Yes they do.


  • :belt_onion:

    @moderator said:

    Hey, why do quote blocks -- literally text from this website which was included in a post for context -- start out collapsed

    What? They don't for me.

    Edit (to join HardwareGeek's camp): Oh, I see.

    @moderator said:

    Actual: Unstoppable nightmare fuel:

    Me: HA HA, I don't know what I did, but somehow I prevented what bstorer was trying to do there-- image appears after taking twenty seconds to load for some God damn reason OH GOD WHY.

    I hate you.



  • @Lorne_Kates said:

    Yes. It either stops before the I, or it jumps past the I-- either deselecting what you have, or selecting the "meta" line (username, time posted, etc), which disables the Quote floater. Or it does both.

    No repro with Chrome on OSX - sounds like your web browser doesn't handle text selection very well. Does triple-clicking on the line/paragraph you want to quote work?



  • @moderator said:

    Actual: Unstoppable nightmare fuel:

    Jesus.. we have 6-inch spiders here and I thought those were bad enough..



  • @heterodox said:

    image appears after taking twenty seconds to load for some God damn reason

    I noticed this, too. For example, some people have posted images but I didn't realize it because there was no image in their post, then I see later that an image has somehow loaded.


  • :belt_onion:

    @morbiuswilters said:

    I noticed this, too. For example, some people have posted images but I didn't realize it because there was no image in their post, then I see later that an image has somehow loaded.

    Oh. Is it a Discourse thing then? How does that even work? (Unless it's running the damn browser out of resources, which is what I decided was happening as behavior got more and more wonky. I like to think that if you look at my last few posts you can see me descend slowly into madness. It's not like I'm running Firefox; for a Web application to do this is not normal.)



  • @dfcowell said:

    Does triple-clicking on the line/paragraph you want to quote work?

    Chrome, Win7: It works if the paragraph is not the last paragraph of the post. Triple-clicking the last paragraph also selects the Reply button (but not the like, flag, etc.???), which breaks the Quote Reply function.

    Hint: The few times I've had trouble selecting just what I want, I selected the entire post using the speech bubble in the editor window, then trimmed the quoted text in the editor.



  • @heterodox said:

    Unless it's running the damn browser out of resources, which is what I decided was happening as behavior got more and more wonky.

    That would not surprise me in the least, because my browsing is getting slower across the board, not just here. Of course, that's not at all unusual for me, Discourse or no, because I have 10793 tabs open all the time.


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.