ImMovable Type



  • <font size="-3">(crossposted to my slashdot journal)</font>

    All in all, I'm pretty impressed with Movable
    Type. It works with postgres, and memcache, and it publishes static
    HTML so it stays performant under heavy load. They do a lot of things
    well.

    Although, the install process sucks. It croaked because I
    didn't have a certain perl library installed. No big deal though; one
    command in CPAN, and that's taken care of. Then it gets into the
    database building phase, and dies. Hard.

    Turns out there's been a show-stopping bug in the release version for over a month. I understand; bugs happen. But when your release version has a bug that prevents installation, you've gotta have a fix out in far less than a month!

    Well,
    I applied the fix mentioned in that post (which involved opening up a
    perl file and adding a line of code), and everything else went smoothly.

    That
    was, until we decided we wanted to copy the installation from our dev
    environment into production. Our graphic artist spent dozens of hours
    setting up templates, building content pages, tweaking the
    configuration, etc. MT has a "import/export" system, but it doesn't
    capture most of these things -- just blog posts. It also has a "backup"
    feature. But apparently the "restore" half of that feature is slated
    for a future release. It's conspicuously absent from the relevant section of the docs. And an unanswered post
    in their forums notes that docs for a future release mention a
    "restore" tab that doesn't exist in the current version. Gee, I really
    hope there isn't some hapless blog admin out there dutifully creating backups that they'll never be able to use.

    I google "moving movable type", and turn up a guide from 2004 that recommends, as part of the process, printing
    pages of the admin interface, and using a pencil to check the
    checkboxes, so you'll have something to refer to when you manually set
    them again
    . That can't be a good sign.

    Alright, fine, I'll
    do this the good old fashioned way. I dump the database to a file, and
    tar it up along with the static content directories, gzip, and scp up
    to production. Unzip. Untar. MT comes up. Good. Republish. Error. It's
    trying to publish to the path the development server used. Huh? The
    config file is pointing to the right place. I put some symlinks from
    the paths the dev server used to the right places. Republish. Success!
    Wait... all these links point to the development server! I grep the
    database dump. Oh, great. The hostname, and the filesystem path are
    stored all over the goddamn database.

    So I did the only thing I
    could. I ran sed to replace the old hostname and path in the database
    dump. It worked. But good god, could this be any worse?

    tl;dr:
    MT's install process was broken for over a month; there's a "backup"
    system but no "restore"; there's no way to move an installation across
    domains; and the paths in your config file are copied all over the
    database.

    This is state of the art blogging software? Face, meet palm.



  • Holy crap, now I remember why I started to write my own.



  • I have only used MTOS for less than a year, and overall, I like it very much - but I've learned it's always the little things that get you in the end.

    Import stuff from other blogs? Well, would love to, but the import format isn't specced well enough, even a non-normative example that demonstrates the capabilities would be nice. (F*ed up when writing the export script, didn't get any categories and tags, so I added them to my ~100 blog entries by hand. It was a surprisingly fast process!)
    I'd like to have Atom API support. Sorry, no - depends on CPAN module and CPAN.pm incidentally blows. (Well, fair enough, that's hardly MTOS' fault.)
    Well, posting stuff to blog over elinks and ssh, like yesterday when my desktop PC's monitor was dead and all I had was my very crappy very old laptop: Beware! You get a blog post with just the title if you don't have Javascript! And if you want to delete or edit stuff in the blog without Javascript, well, better fire up the Opera. (<5 minutes of actual blog post editing, ~30 minutes watching the bloody sneaky viking browser operate the bloody swap partition.)
    ...little things like this.

    Weird, however, that you can't restore backups - because that was exactly what I did when I imported the old blog posts to my blogs: Write a converter script that spits out MT backup file, then load that thing up in MT. Supports MT's own format and Wordpress format, last I checked. However, last I checked the import feature was pretty damn well hidden and I can't remember offhand were the hell it is.

    (Obligatory semi-serious semi-provocative comments:)
    Movable Type: the worst blogware except all those other blogwares that have been tried from time to time.
    Movable Type: blows a little bit less than Wordpress.



  • @WWWWolf said:



    Movable Type: blows a little bit less than Wordpress.
    Except for the fact that the WordPress export/import functionality actually works.



  • @TheRider said:

    @WWWWolf said:



    Movable Type: blows a little bit less than Wordpress.
    Except for the fact that the WordPress export/import functionality actually works.

    Sure, probably allowing everyone everywhere import stuff in the blog, knowing WordPress' security track record. Luckily, I don't know why anyone would want to do that, because by default, the Wordpress permalink format blows so it's worthless for blackhat SEOs. And if you have some other database besides MySQL, tough. Want multiple blogs? Er, it's a whole separate package...

    And like I said, it's highly weird that we have two users - for one, import doesn't seem to work while export does, and for another (me), import seems to work as perfectly as it can under the circumstances and they haven't tried how the export works. Such is the way of Software.

    Look, I marked my above comment as "semi-serious" and "semi-provocative" in hopes it'd not cause weird sidetracks. I'm sorry I wasn't clear enough. Let's end the flamewar at the beginning - it wasn't my idea to start one, and I tried (and failed) to mark my comment as potentially offensive for a reason - and let me state for emphasis that it is my firm belief that ALL SOFTWARE SUCKS. =)


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.