Request for linux (SUSE) help... please!



  • i know this isn't a technical support forum or anything... but this has plagued me for the last ten hours.

    First i had my computer catch on fire. yes, CATCH ON FIRE.

    I finally got that figured out, and so i decided to install SUSE 0.2 x86-64.

    I did the full internet install, updated all packages and all that.

    I installed wine.

    wine wow.exe -opengl

    Errors out with "no accellerator"

    Queue ati.com proprietary driver install.

     

    Fast forward 5 hours. Ok, so i can get to the desktop again... but it's set at 1600x1200, and my monitor can only handle 1280x1024.

    So it does that thing where you move the mouse to the edge to scroll around. whatever. wine wow.exe -opengl

    IT WORKS!

    Do all the other 3d tests, superb!

     

    Here's the RUB, gentlemen.

     

    I can only boot my system into init 5 if i unplug my monitor from the computer.

    You heard me right.

    If i leave everything alone, power the system on, it gets past init 3 just fine, goes to drop into init 5, and BOOM, blinking monitor light. plug in analog monitor cable? A brighter shade of black, no blinking light.

    If i unplug while suse is loading it's load files, and plug back in when the GDM is waiting for a username (the Xwindows)... magically one or the other (DVI or analogue) will be working... at 1280x1024...

    xorg.conf doesn't have a setting in it for 1600x1200... it has MY monitor (samsung syncmaster 930b) listed as the screen...

    modes all say 1280x1024 (or lower)... the syncs look to be in range for the monitor (i dug out the manual)

    everything works, i just have to unplug the monitor every time... i have tested this about 25 times now, rebooting, monitor off, rebooting with one cable plugged in, rebooting with both unplugged, ETC.

    I followed the wiki on x86-64 howto on the suse wiki for the ATI drivers to get the opengl away from mesa and into ATI... everything there checks out.

    i am typing to you now from Gnome... after rebooting with the monitor cables unplugged.

     

    Here are the quick and dirty stats

    SUSE 10.2 64 bit fully upgraded (and latest patches, etc)

    2 gigs system memory

    160 gig HD

    xorg.conf looks clean

    ATI x800 gl 256 AGP video card (reported as an ati x800 XL PCI-E to SaX2)

     

    samsung syncmaster 930b

     

    I think the problem is in the xorg.conf when SOME damn thing looks up what monitor is connected and it tries some obnoxious resolution or refresh rate... but what is overriding my xorg.conf?

     

    any thoughts?

     



  • oh, a couple of quick notes...

    YAST monitor and video card config hangs when i try to save settings, as does sax2 -r -m 0=fglrx

    it says "sax2 has aquired a screen" or something similar (in the console) and just sits there randomly making my screen go black, and then bringing back gnome.

     

    If the answer is a reinstall, use KDE, reinstall and do X, etc, i don't mind... i just want to put this particular issue behind me.
     



  • @GeneWitch said:

    i know this isn't a technical support forum or anything... but this has plagued me for the last ten hours.

    First i had my computer catch on fire. yes, CATCH ON FIRE.

    I finally got that figured out, and so i decided to install SUSE 0.2 x86-64.

     

     

    Ok, a little (good natured, really!) aside, then my take on it... 

     

    I just picture you sitting there at your desk, coding away at some hard problem.  Suddenly the screen goes blank and the computer powers down, and you lose your work!

    You push the computer's on button, nothing happens.  Ok, no big deal, the fuse blew or you kicked the wall jack.   You check the power strip, see the little red light, no breaker issue.  You check the power cord into the computer, (ouch! seems to be hot).   What's that beeping coming from the hallway?  Sure is loud enough to wake somebody up.  Shouldn't be related.   What's the wife yelling about?   Dang, she lost her job again. 

    Maybe there's a problem with the ACPI support in the power supply, perhaps if I leave it for a few seconds....

     Wait, the wife never had a job, she takes care of the baby.   ...   ....   .....   .....   ....  Oh, no, she's not saying "fired", she's saying "fire!"    That's what's wrong with the computer!

    ----

    I had a lot of video issues when I installed a shouldn't-have-been-but-was underpowered PSU in my computer.   It turned out that I had overloaded one of the rails (+5?) but was under the total wattage rating.   The video card wasn't able to function correctly when I had a lot of things going on.  The tech at BFG told me to unplug my USB mouse because that was enough to tip it over the edge (But I'm not sure I believe that).  I just intalled a beefier PSU and everything worked fine.

     A fire in your case could have damaged something enough to cause lowered voltages or some such.  I have a CS degree, not CompE so, I just know enough to make myself sound stupid, so I'll be quiet from here out.

     



  • Also, I say it could be a power issue because during bootup all the components are being initialized, so more power is being used.  If you don't plug in the monitor, that's one less thing the computer has to do once it discovers that there's nothing there.   After bootup, there's more power to run the monitor since the computer isn't spinning all the fans and HDDs and the CPU has calmed down.

     What happens if you boot without the monitor, plug it in and launch some really CPU and HDD intensive programs?
     



  • Maybe you should post your xorg.conf, just so we can say for sure it doesn't say 1600x1200.

    If that doesn't help, try renaming xorg.conf to U_wont_find_this_suXXX0r.conf and see if anything changes. If not, those clever guys at suse have found a better place for their copy of xorg.conf. 



  • You have an ATI card?
    You want it to actually work?
    You want to play games?
    You need a system that doesn't crash?

    Welcome to Microsoft Windows XP, the software that actually works.

    If you value your time and sanity, just use what works. I've given up on ATI's horrible, horrible support and while I won't ever buy their hardware again, I'm stuck with this card until it needs to be replaced. So Windows it is. 

     Edit: Hahahahahah, I just realized you're trying to do all of this on a 64-bit system! Wow. Why not try to get two monitors working at the same time too. </sarcasm>
     



  • @GeneWitch said:

    I can only boot my system into init 5 if i unplug my monitor from the computer.

    Sounds like it's trying to probe the monitor for its capabilities, and failing miserably.  I don't have an ATI card anymore (thank Paula), but Google seems to think that

    Option "NoDDC"
    in xorg.conf, in the "Device" section mentioning fglrx, will disable that.


  • Try an NVidia video card. I wouldn't be surprised if all the issues cleared (after installing the drivers that is). ATI's linux drivers are the main reason I stick to NVidia.




  • # /.../
    # SaX generated X11 config file
    # Created on: 2007-02-16T12:38:22-0800.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "ServerLayout"
        Identifier     "Layout[all]"
        Screen      0  "aticonfig-Screen[0]" 0 0
        InputDevice    "Keyboard[0]" "CoreKeyboard"
        InputDevice    "Mouse[1]" "CorePointer"
        Option        "Clone" "off"
        Option        "Xinerama" "off"
    EndSection

    Section "Files"
        InputDevices   "/dev/gpmdata"
        InputDevices   "/dev/input/mice"
        FontPath     "/usr/share/fonts/misc:unscaled"
        FontPath     "/usr/share/fonts/local"
        FontPath     "/usr/share/fonts/75dpi:unscaled"
        FontPath     "/usr/share/fonts/100dpi:unscaled"
        FontPath     "/usr/share/fonts/Type1"
        FontPath     "/usr/share/fonts/URW"
        FontPath     "/usr/share/fonts/Speedo"
        FontPath     "/usr/share/fonts/PEX"
        FontPath     "/usr/share/fonts/cyrillic"
        FontPath     "/usr/share/fonts/latin2/misc:unscaled"
        FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
        FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
        FontPath     "/usr/share/fonts/latin2/Type1"
        FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
        FontPath     "/usr/share/fonts/baekmuk:unscaled"
        FontPath     "/usr/share/fonts/japanese:unscaled"
        FontPath     "/usr/share/fonts/kwintv"
        FontPath     "/usr/share/fonts/truetype"
        FontPath     "/usr/share/fonts/uni:unscaled"
        FontPath     "/usr/share/fonts/CID"
        FontPath     "/usr/share/fonts/ucs/misc:unscaled"
        FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
        FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
        FontPath     "/usr/share/fonts/hellas/misc:unscaled"
        FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
        FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
        FontPath     "/usr/share/fonts/hellas/Type1"
        FontPath     "/usr/share/fonts/misc/sgi:unscaled"
        FontPath     "/usr/share/fonts/xtest"
        FontPath     "/opt/kde3/share/fonts"
        FontPath     "unix/:7100"
    EndSection

    Section "Module"
        Load  "glx"
        Load  "type1"
        Load  "extmod"
        Load  "dbe"
        Load  "freetype"
        Load  "v4l"
        Load  "dri"
    EndSection

    Section "ServerFlags"
        Option        "AllowMouseOpenFail" "on"
        Option        "IgnoreABI" "on"
    EndSection

    Section "InputDevice"
        Identifier  "Keyboard[0]"
        Driver      "kbd"
        Option        "Protocol" "Standard"
        Option        "XkbLayout" "us"
        Option        "XkbModel" "pc104"
        Option        "XkbRules" "xfree86"
    EndSection

    Section "InputDevice"
        Identifier  "Mouse[1]"
        Driver      "mouse"
        Option        "Buttons" "10"
        Option        "Device" "/dev/input/mice"
        Option        "Name" "Razer Copperhead Laser Mouse"
        Option        "Protocol" "explorerps/2"
        Option        "Vendor" "Sysp"
        Option        "ZAxisMapping" "4 5"
    EndSection

    Section "Modes"
        Identifier     "Modes[0]"
    EndSection

    Section "Monitor"
        Identifier   "aticonfig-Monitor[0]"
        Option        "VendorName" "ATI Proprietary Driver"
        Option        "ModelName" "Generic Autodetecting Monitor"
        Option        "DPMS" "true"
    EndSection

    Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
    EndSection

    Section "Screen"
        Identifier "aticonfig-Screen[0]"
        Device     "aticonfig-Device[0]"
        Monitor    "aticonfig-Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
            Viewport   0 0
            Depth     24
        EndSubSection
    EndSection

    Section "DRI"
        Group        "video"
        Mode         0660
    EndSection

    Section "Extensions"
        Option        "Composite" "true"
        Option        "DAMAGE" "false"
    EndSection

     

     

    Just so you know, this damn xorg.conf changes everytime i reboot.

    My LCD is currently bitching that the resolution is too high. 

    whenever SAX2 doesn't decide to BARF all over everything, the modes section has a bunch of 1280 resolution listings.
     

    I'm pretty much sick of this. This xorg.conf file is the one that isn't realzing that i have the fglrx driver installed, therefore a xglxinfo states that i am using mesa 3d... which doesn't do me any damn good.

    I'm starting to think the hardware is fried, i went to try and recover my other HD (with XP x64 edition on it) and it hangs on "detecting hardware"

     

    I'm wondering if "UNPLUG MONITOR FOR 15 SECONDS" is gunna be a valid workaround for this issue.

     I've edited xorg.conf so many times i could list off the features in my sleep, and i KNOW that this current xorg.conf is WRONG.

    God only knows what happened to the one i saved that had :

    Section "Screen"
        Identifier "Screen[0]"
        Device     "Device[0]"
        Monitor    "Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
            Depth     15
            Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
        EndSubSection
        SubSection "Display"
            Depth     16
            Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
        EndSubSection
        SubSection "Display"
            Depth     24
            Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
        EndSubSection
        SubSection "Display"
            Depth     8
            Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
        EndSubSection
    EndSection

     and
     Section "Modes"
        Identifier     "Modes[0]"
        ModeLine     "1280x1024" 107.0 1280 1360 1496 1712 1024 1025 1028 1059
        ModeLine     "1280x1024" 87.8 1280 1328 1360 1440 1024 1027 1034 1053 +hsync -vsync
        ModeLine     "1280x960" 107.3 1280 1360 1496 1712 960 961 964 995
        ModeLine     "1280x960" 88.2 1280 1328 1360 1440 960 963 967 989 +hsync -vsync
        ModeLine     "1152x864" 105.0 1152 1224 1352 1552 864 865 868 902
        ModeLine     "1152x864" 96.8 1152 1224 1344 1536 864 865 868 900
        ModeLine     "1152x864" 89.6 1152 1224 1344 1536 864 865 868 897
        ModeLine     "1152x864" 86.8 1152 1200 1232 1312 864 867 871 895 +hsync -vsync
        ModeLine     "1152x864" 81.6 1152 1216 1336 1520 864 865 868 895
        ModeLine     "1024x768" 81.8 1024 1080 1192 1360 768 769 772 802
        ModeLine     "1024x768" 76.2 1024 1080 1192 1360 768 769 772 800
        ModeLine     "1024x768" 69.7 1024 1080 1184 1344 768 769 772 798
        ModeLine     "1024x768" 69.5 1024 1072 1104 1184 768 771 775 796 +hsync -vsync
        ModeLine     "1024x768" 64.1 1024 1080 1184 1344 768 769 772 795
        ModeLine     "800x600" 48.9 800 840 920 1040 600 601 604 627
        ModeLine     "800x600" 45.5 800 840 920 1040 600 601 604 625
        ModeLine     "800x600" 44.0 800 848 880 960 600 603 607 622 +hsync -vsync
        ModeLine     "800x600" 42.1 800 840 920 1040 600 601 604 623
        ModeLine     "800x600" 38.2 800 832 912 1024 600 601 604 622
    EndSection

    in it. at least that one was running on the DVI. and i could play games... and everything worked peachy... except that god forsaken inability to  boot without unplugging the monitor. (btw... numlock turns off after the "select boot options" screen... then comes back on after about 10 seconds... i hit escape (to see the scrolling text while it boots)

    I unplug the monitor right after that... and wait for the numlock light to turn off (means gnome is waiting for me to input username)

    Plug analogue back in... and it works... well... sometimes. depending on what has gone and re-edited the xorg.conf without asking me.

     

    I give up. i'm waiting for my new un-fired PC to get here (on monday, i think... shipped today)

    and then i'll figure out WTF is wrong with this one and make it into a ... paperweight.

     

    This is slightly too frustrating.
     



  • don't forget this bit

    Section "Monitor"
      DisplaySize  376 301
      HorizSync    30-81
      Identifier   "Monitor[0]"
      ModelName    "SAMSUNG SYNCMASTER"
      Option       "DPMS"
      VendorName   "SAM"
      VertRefresh  43-75
      UseModes     "Modes[0]"
    EndSection

     

    /sigh.

    --gene. 



  • @Nandurius said:

    You have an ATI card?
    You want it to actually work?
    You want to play games?
    You need a system that doesn't crash?

    Welcome to Microsoft Windows XP, the software that actually works.

    If you value your time and sanity, just use what works. I've given up on ATI's horrible, horrible support and while I won't ever buy their hardware again, I'm stuck with this card until it needs to be replaced. So Windows it is. 

     Edit: Hahahahahah, I just realized you're trying to do all of this on a 64-bit system! Wow. Why not try to get two monitors working at the same time too. </sarcasm>
     

    ya i'm a fakkin rebel, ey.

    Someone said that SUSE had taken linux to the next step (i used to run redhat, as i think i mentioned) so i know how to manually install EVERYTHING with source files... I don't like doing that... they're like "YAST FIXES IT!" and so i am using yast... and now it just crashes... the perl script has a bug in it somewhere. I'm debating whether i want to give ubuntu a try, or just call it quits with this system.

    PS... the 64 bit system worked perfectly until i tried to get an opengl accellerated system working.

    who knows? 



  • edit time-outs are the devil.

    For the record, at around 7-8 AM this morning, i was logged into wow via "wine wow.exe -opengl" at a clean 30FPS windowed... which was a good start. i needed to reboot to get some other update to run and then i started with the "unplug monitor, re-edit xorg.conf, ldconfig, etc etc etc etc etc etc reboot, pray, cuss, pray, cuss some more and start over" 



  • @GeneWitch said:

    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!

    ... 

    Just so you know, this damn xorg.conf changes everytime i reboot.

    OK, looks like you'll need to find a way to control the autogenerating thing (or at least disable it, so you can edit manually). 


    Section "DRI"
        Group        "video"
        Mode         0660
    EndSection

    ... 

    I'm pretty much sick of this. This xorg.conf file is the one that
    isn't realzing that i have the fglrx driver installed, therefore a
    xglxinfo states that i am using mesa 3d... which doesn't do me any damn
    good.

    That section will only let you use 3D if you're in the video group.  Are you?  Another possibility:

     

    Section "Extensions"
        Option        "Composite" "true"
        Option        "DAMAGE" "false"
    EndSection

    If you're using fglrx, you need to disable Composite, or you won't get 3D acceleration.  (Tangent, and nothing to do with your problem, but enabling Composite and not DAMAGE is a bit of a WTF in itself, AFAIK.)


    I'm starting to think the hardware is fried, i went to try and recover my other HD (with XP x64 edition on it) and it hangs on "detecting hardware"

    Based on the Linux problems I'd say that's unlikely, probably just screwy software, although it's a bit worrying that XP doesn't like it either.



  • @iwpg said:

    OK, looks like you'll need to find a way to control the autogenerating thing (or at least disable it, so you can edit manually). 

    i wish i knew how. :-/ SaX2 is a whole new ballgame. i'm used to XFree86Config. 

    @iwpg said:

    That section will only let you use 3D if you're in the video group.  Are you?  Another possibility:

     

    Yes, at least on UID 1000 (i would assume root would be a member of all groups?) But this is occuring before log in, so either way. 


    @iwpg said:

    If you're using fglrx, you need to disable Composite, or you won't get 3D acceleration.  (Tangent, and nothing to do with your problem, but enabling Composite and not DAMAGE is a bit of a WTF in itself, AFAIK.)

    Composite true was something i had enabled to get xgl (the pretty windows vista emulator/desktop enhancement suite) working. Damage was added in by a script along the line. i'll switch composite to false. 

    @iwpg said:

    Based on the Linux problems I'd say that's unlikely, probably just screwy software, although it's a bit worrying that XP doesn't like it either.

    It could just be a really broken video card. or ram, or anything. 



  • I'm wondering if i can chmod xorg.conf as root to read only... but i have a feeling that the sax2 is operating 'sudo'



  • @GeneWitch said:

    ya i'm a fakkin rebel, ey.

    Someone said that SUSE had taken linux to the next step (i used to run redhat, as i think i mentioned) so i know how to manually install EVERYTHING with source files... I don't like doing that... they're like "YAST FIXES IT!" and so i am using yast... and now it just crashes... the perl script has a bug in it somewhere. I'm debating whether i want to give ubuntu a try, or just call it quits with this system.

    PS... the 64 bit system worked perfectly until i tried to get an opengl accellerated system working.

    who knows? 

    IMO, Suse sucks.  Especially on the desktop.  I much prefer (k)ubntu on the desktop and red hat on the server.  The only reason I've ever wanted to install Suse was because it was one of the few distribs that offered an UltraSparc version.  Even then, I decided it was too much trouble and just threw the Sun server out - the filesystem's on Sun's drives just randomly lost their partition tables. 

    I got a cluster of Suse Enterprise servers at work (installed prior to me starting).  It was such a pain in the ass to get Tetex/Latex installed correctly as the rpms didn't work - I had to install from source.  Not very good for succession planning since I'm the only one with linux experience.  They almost had a cow when I deleted a invalid symlink to a package's INSTALL file.  The phantom symlink was causing the backup to throw warnings. 



  • Ok so SUSE is out (at least on this machine)

    I might try dualbooting the new machine (delivered on tuesday... i had forgotten to buy new ram so i went and got that today!)

    But for this one, it looks like i am sticking with XP x64. Hey, it works. It does it's huge uptimes with no crashing, or anything.

    I really wanted to have this be a machine for development... so i'll look in to ubuntu on this one after the new computer arrives.

    thanks for your witty, and helpful responses (i did try everything you guys mentioned and then some!)

     

    --Gene, the forum NickNewGuy()



  • If you only need it for development, why not run Linux in VMWare player?



  • @Nandurius said:

    Why not try to get two monitors working at the same time too. </sarcasm>

    You should try to run 2 monitors, one on an ATI card and one on an NVidia card. God, I still have nightmares about that. 


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.