Outlook 2010 forcing 8.3 filenames?!



  • Has anyone else noticed this? All I did was right click the file in Explorer and choose Send to > Mail recipient:

    Redacted_training_v8.2.doc becomes I4A5QE~T.DOC.

    I just tried another file (without the extra dot) and it worked properly.  Yay for testing.




  • FWIW, unable to reproduce in Vista/Outlook 2007.

    Could be a regression in Outlook, or of Send To.



  • I suppose Outlook actually copies the file you try to attach to a temporary directory and then sends that instead of the "real" thing, and has here choked on the [i].2.doc[/i] bit somehow …

    The proper 8.3 name for this document would be [i]I[/i] followed by the next seven letters you made illegible — or [i]I[/i] followed by the next five letters and then [i]~1[/i], [i]~2[/i], etc. depending on how many other files in the same directory would get the same name — and then [i].DOC[/i].



  • @Gurth said:

    I suppose Outlook actually copies the file you try to attach to a temporary directory and then sends that instead of the "real" thing, and has here choked on the .2.doc bit somehow …

    Huh? The first part seems to fully answer this. It appears to have copied it to a temp directory with a random name (presumably with collision checking). End of story.



  • @Gurth said:

    The proper 8.3 name for this document would be I followed by the next seven letters you made illegible — or I followed by the next five letters and then ~1, ~2, etc. depending on how many other files in the same directory would get the same name — and then .DOC.

    Not necessarily - on Windows 2000 and later, it stops at "~4" and instead switches to using the first [b]2[/b] characters of the filename plus 4 hexadecimal digits (based on some filename hash) and "~1", plus the usual stuff for the extension. In this case, though, it's seemingly Outlook itself that generated the odd shortname.



  • To ask a stupid question, is your computer's filesystem Fat32 or NTFS?



  • What OS is that? Was it an upgrade of Outlook from previous version?

    I don't see this behavior in my Win7/x86+Outlook 2010.

    I wonder how Win7/x64+Outlook x86 would do.



  • Looks like the default Samba name mangling. This does not explain why Outlook used the short name, though.



  • @fatbull said:

    Looks like the default Samba name mangling. This does not explain why Outlook used the short name, though.

    It wouldn't shock me to learn that Outlook uses the short name on Fat32-formatted disks, and Windows XP supports both Fat32 and Outlook 2010. Which is why I asked.



  • @blakeyrat said:

    @fatbull said:
    Looks like the default Samba name mangling. This does not explain why Outlook used the short name, though.

    It wouldn't shock me to learn that Outlook uses the short name on Fat32-formatted disks, and Windows XP supports both Fat32 and Outlook 2010. Which is why I asked.

    It's windows 7 32 bit (work pc only has 2GB ram, but it is not my primary computer). File was on samba server. Local file system is ntfs. I'll copy the file to Desktop today and see what it does.



  • I copied the file to a bunch of other folders, even on the same share and could not reproduce the problem. Then I noticed there was a bullet symbol on the end of the folder name in Windows. On the Mac in the Finder it just looks like a trailling space. When sshing into the Linux Samba server the trailling symbol doesn't appear at all when using "ls -lb", but changing into it bash autocompletes with a "/ " on the end, then when it's the cwd there's an invalid looking character on the beginning of the command line. I tried accessing it through Terminal from the Mac, then "pwd | pbcopy" and there appears to be a newline on the end of the folder name.

    So I guess the WTF is people using Macs to access a Samba server.



  • @Zemm said:

    So I guess the WTF is a Samba server that hasn't been configured to preserve/translate/drop specific characters in the filename

    In before Blakey gets restarted on his rant about filenames containing "forbidden characters".



  • @Cassidy said:

    @Zemm said:

    So I guess the WTF is a Samba server that hasn't been configured to preserve/translate/drop specific characters in the filename

    In before Blakey gets restarted on his rant about filenames containing "forbidden characters".

    I did some searching and my google-fu has failed me. How do I make it fail on so-called forbidden chars? It's obvious it preserves newlines between macs and Linux, and translates for windows. It's a wtf that one can put newline chars in via finder (the owner of the dir was a non-technical person). Sometimes people make files with a > or ? And they just fail with a obscure error message when copying to any SMB server (real windows or samba). But newlines are fine!?



  • ISTR it's the "veto files" option and you need to add some regex to block files containing specific characters. I've done it to prevent SWMBO's Mac vomiting .DS_ filesinto our shared regions.[1]

    There is another option that does a character translation - something like replacing spaces for underscores. I've got Tridgell's book at home (the actual book used to be downloadable as one huge PDF at one time from O'Reily's website, not sure if that still exists as an option), I'll have to leaf through.

    [1] stop sniggering at the back, there.

     



  • @Zemm said:

    I did some searching and my google-fu has failed me. How do I make it fail on so-called forbidden chars? It's obvious it preserves newlines between macs and Linux, and translates for windows. It's a wtf that one can put newline chars in via finder (the owner of the dir was a non-technical person). Sometimes people make files with a > or ? And they just fail with a obscure error message when copying to any SMB server (real windows or samba). But newlines are fine!?

    According to MS, it seems so:
    @MSDN said:

    • Use any character in the current code page for a name, including Unicode characters and characters in the extended character set (128–255), except for the following: The following reserved characters:
      • < (less than)
      • > (greater than)
      • : (colon)
      • " (double quote)
      • / (forward slash)
      • \ (backslash)
      • | (vertical bar or pipe)
      • ? (question mark)
      • * (asterisk)

Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.