Replies and Community Server


  • Discourse touched me in a no-no place

    Why the hell is it that when I post a reply, the post never appears immediately in the thread? Even if I refresh immediately, the post doesn't appear. There seems to be a waiting period of a few seconds before you can reload the thread and see the new reply.

    What the fuck? How do you even write forum software that does that kind of shit? I'd love to look at the source for this junkheap some time.



  • @Weng said:

    Why the hell is it that when I post a reply, the post never appears immediately in the thread?
    Another symptom similar to previous ones such as:

    • Email subscriptions going missing
    • Post limits even a twatterer would be proud of



      I've noticed it myself on occasion, but tends to be around 1800-2000 UTC - when I presume quite a few people are using the boards - the posts I've made this morning have appeared as I've posted them.



      Edit - this one included.


  • @PJH said:

    * Email subscriptions going missing

    • Post limits even a twatterer would be proud of
     

    These are genuine bugs, with causes that can be solved.

     Wengs issue has been around forever. It appears to be by design. Some sort of caching, I guess.



  • @dhromed said:

    @PJH said:

    * Email subscriptions going missing

    • Post limits even a twatterer would be proud of
     

    These are genuine bugs, with causes that can be solved.

     Wengs issue has been around forever. It appears to be by design. Some sort of caching, I guess.

    It might be spawning threads to do database work that isn't "necessary" to displaying the next page. I mean, I do that with a app we have where I want to give a quick reply to the browser, but I need to do 5-10 seconds of database work behind the scene-- the reply to the browser doesn't require the DB work to be done yet.

    Of course, in this case, displaying the thread *does* require the DB work to be done, as you can't use the Edit button on your post until your post is visible... so... fail.


  • Discourse touched me in a no-no place

    @PJH said:

    Email subscriptions going missing
    Also, email subscriptions turning on without reason.

    Turns out I was subscribed to this thread. Not that the emails actually managed to arrive or anything.

     

    Edit: Apparently it subscribes me to everything I reply to, and the "Options" tab up there contains the checkbox for it. This is a STUPID, hateworthy default. And editing my profile to turn it off reveals this WTF:

     

        <div class="CommonMessageSuccess">"Your profile has been updated.  It may take up to 10 minutes for changes to take effect."</div></div><p>&nbsp;WHY THE FUCK IS THAT?</p><p>&nbsp;</p><p>Also, the index page still shows blakey as the most recent poster in this thread. This thing is full of hideous, horrible, utterly pointless caching. <br></p>


  • @Weng said:

     WHY THE FUCK IS THAT?

    Because it is Community Server, what do you expect?  Every forum software has some sort WTF in it, including the MSDN forums so...



  •  Oh come on, what you want to expect? I agree with serguey123, It'a community server dude. Relax :)



  • Community Server stopped sending update emails again... I'm guessing the DB is filling up once more.



  • @blakeyrat said:

    Community Server stopped sending update emails again... I'm guessing the DB is filling up once more.

    what is need to read email notice? best come to site to see latest post. also there is "F5" for refresh.



  • @Nagesh said:

    @blakeyrat said:

    Community Server stopped sending update emails again... I'm guessing the DB is filling up once more.

    what is need to read email notice? best come to site to see latest post. also there is "F5" for refresh.

    Well, for one thing, it gives you a clue when CS is about to vomit all over itself, as the email is the first part to go.



  • @blakeyrat said:

    @Nagesh said:

    @blakeyrat said:

    Community Server stopped sending update emails again... I'm guessing the DB is filling up once more.

    what is need to read email notice? best come to site to see latest post. also there is "F5" for refresh.

    Well, for one thing, it gives you a clue when CS is about to vomit all over itself, as the email is the first part to go.

    Also the site is slow when browsing when you are logged, so you need to do stuff like keep one page logged and another unlogged which is a pain or keep logging in and out which is a more of a pain.

    However it seems that CS is not alone today, the MSDN forum is acting up again as well, they are having problems since the 3/17/2011



  • @serguey123 said:

    Also the site is slow when browsing when you are logged, so you need to do stuff like keep one page logged and another unlogged which is a pain or keep logging in and out which is a more of a pain.
     

    It's decidedly less slow in FFX4. It's decidedly fast/normal in Chrome and Opera. I dn't know what FFX does, or what CS does, that makes it slower. Something about cached connections or waevs.

    Also, I:

    - open subforums in tabs in one go

    - go tab by tab and open all new threads in new tabs.

    Now I have a big set of tabs with fresh TDWTF content. Don't underestimate the power of batch actions.



  • @dhromed said:

    @serguey123 said:

    Also the site is slow when browsing when you are logged, so you need to do stuff like keep one page logged and another unlogged which is a pain or keep logging in and out which is a more of a pain.
     

    It's decidedly less slow in FFX4. It's decidedly fast/normal in Chrome and Opera. I dn't know what FFX does, or what CS does, that makes it slower. Something about cached connections or waevs.

    Also, I:

    - open subforums in tabs in one go

    - go tab by tab and open all new threads in new tabs.

    Now I have a big set of tabs with fresh TDWTF content. Don't underestimate the power of batch actions.

    I do that as well, but that is also a pain, you get a gazillion tab, the only saving grace is that this forums are not very active



  • @blakeyrat said:

    @Nagesh said:

    @blakeyrat said:

    Community Server stopped sending update emails again... I'm guessing the DB is filling up once more.

    what is need to read email notice? best come to site to see latest post. also there is "F5" for refresh.

    Well, for one thing, it gives you a clue when CS is about to vomit all over itself, as the email is the first part to go.

    She's going down in flames!



  • As predicted, forum's fucked. Please fix.



  • @blakeyrat said:

    As predicted, forum's fucked. Please fix.
     

    hu?



  • @dhromed said:

    @blakeyrat said:

    As predicted, forum's fucked. Please fix.
     

    hu?

    My feelings exactly, CS is not fixable, we can only hope it dies



  •  I've been away for the weekend. I must have missed a breadown and a fix.



  • @dhromed said:

     I've been away for the weekend. I must have missed a breadown and a fix.

    Someone can rise to ocasion and bake a joke out of it!


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.