IIS 6.0/.Net Target Framework 1.1 vs 2.0



  • I developed a couple webservices in VS 2008 for a customer and installed them on their test server with target framework 2.0 - this worked fine. Now they're going into production where they have .Net 1.1 installed on their IIS 6 and it seems to have issues with my 2.0 services.

    I played around with the target framework and got my services working, but then a colleague came barging in asking if we'd changed anything that broke the internal website and it turned out that indeed, either that site on 1.1 worked fine, or my webservice on 2.0 worked, but not both.

    So far I'd say IIS 6.0 is the real WTF but now it gets weirder: they also have another app on 2.0 on the same server that seems to run fine (I had to leave in a hurry and couldn't check all settings). This I don't get. Does it just hate me (possible) oris there a setting I should check?

    They're not going to upgrade IIS for me, and VS 2008 can't compile for 1.1, so I have to figure sth out. Any smart ideas would be appreciated.

     



  • Create a new application pool for your app.

    You can have multiple versions of ASP.NET hosted through the same IIS instance, but the apps must be in different pools.



  • Thanks, that explains it.

    I found that the application pool for that one app was different, set my services to the same pool, and hey presto. And now I understand why :-)


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.