I wanna become a member !!



  • Yeah Oracle, if I could erase anything from softwareland, it'ld probably be Oracle.

     Since my experience is some 10 years ago and I have not ever touched Oracle after those damned 2 years, I might have some names/versions wrong anyways. Of course some of it has to be blamed on the oracle experts, not just oracle:

    I had to work on a very large database, containing stuff for a pension fund, the payments and so on. Not one table had a primary key. None. They never ever heard of it. Go figure.

    Anyways, designer and developer (i believe version 6, for windows) were just introduced and the company's approach was to make everything in there. I believe before that they had this unix variant (version 4?).

    This "Developer" thing is like what's now called an IDE. You could write procedures in there, store them and test them. And I had too. Followed some examples, typed them in compiled them and ran them. Yay works cool.

    Changed a bit, compiled it and ran it again.  Humz, same result as before? Shouldn't I get something different. Let's see, yeah, code is ok. I should get (whatever) but not that. Must be me, checked everything again. Changed something else. Compile: ok. , Run: ok. Result: fails, same outcome.

    After banging my head on the wall for a few hours, reading the documentation, the examples, examining the 'Developer'. I couldn't find why I don't get the correct result. Asked a co-worker. He ofcourse blamed my code. Another co-worker, didn't know. And co-worker 3: "Have your pressed ctrl-T?" Ctrl what? Why? "Well, then it deletes your compiler output!"

    This "ctrl-t" was no-where documented. No-where. It was not in the menu's, shortcut listings, manuals, hard-copy manuals.No where.

    Coming from a Delphi environment, I feared for the worst. But that had yet to come. 

    Anyways, now I knew how to actually get my *changed* code to run, I started moving my generic Pro-C code to the a database function library. (Not sure, i think the language was PL/SQL?). Anyways, I ran into my first problem. I just couldn't enter any more characters into the editing screen. The damn thing had a limit at 16k....(This was actually caused by the NT memo control used by notepad, used by 'Developer'). Anyways, "go ring the support desk". And I did. They never heard of it. Humz, I'm I the first one to actually make such a function library?

    O well, the solution was to split it into multiple libraries. Ok, sounds good. So I did... First test, what? Cant call a function from a library that resides in a different library? Wtf? Now what? Rang the support desk again.....

    Appeared that I just had to split everything in 30 or so libraries, each containing all their support functions. Try telling a C programmer to copy all code from stdio to every seperate C file he has. I bet you won't survive that.

    Eventually I just gave up on this and demanded another assignment. I stayed with my Pro-C (C++) files and my delphi project(s) for a bit, left the company pretty soon after ;)

    Weps

     

     

     

     

     

     

     


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.