VMWARE workstation bridge issue: plz advise



  • I want to run IPCop inside vmware workstation on my XP host. I have it
    set up, installed (i have the appliance from vmware), and the network
    is set up red -green with eth0 as green (which is working great,
    leasing IPs and everything) and eth1 as red.
    Here's the problem. I
    have a cable modem plugged into my nic via ethernet cable. I have
    vmnet0 and vmnet1 set to bridge to the appropriate NICs. I can't lease
    an IP on eth1 no matter what i try. I think this is because my ISP
    won't lease me two IPs. So i tried giving my host's nic a BS ip
    (1.1.1.1, 192.168.100.25, etc) and tried to get it to come up that way.
    no dice. I tried letting the host lease a public IP, no dice (inside
    vmware, that is, the host leased it just fine).

    I tried using
    "NAT" inside the "network config" for the VM itself, nothing doing. I
    really really really want to use ipcop as my firewall, and there has to
    be some nifty trick to convince windows to let vmware use the adapter
    all on it's own, without interfering. Anyone know what i have to do?

    when
    i bring up ipcop's web interface, and hit connect, and i type ifconfig
    in the guest OS, it says eth1 is there, but with no IP. once the web
    page refreshes (still saying idle); ifconfig shows no eth1. I've run
    "setup" on the guest OS, everything is as it should be.

    I've used IPcop on real hardware hundreds of times, and i've been trying to get this VMware stuff to work properly.

    The
    goal, of course, is to have the HOST OS and ALL other machines on the
    network connected through ipcop's eth0 (green) interface to get on the
    network via ipcop's red interface (eth1); WITHOUT the host being able
    to be accessed via the red interface's physical NIC. if that makes
    sense. the user guide gives no hints as to how to do this, and a
    cursory search on Google yields nothing.

    any ideas?



  • If I understood correctly you want the physical NIC to be dedicated to the VMware. I remeber that this could be done by disabling all protocols from the network connection properties except the VMware Bridge Protocol. This way the host can't access the network through the adapter and it still remains visible to the guest os.

     Btw, This is my first post here so hello everybody!
     



  • Em, I'm quite confused as to what your exact problem is, I presume eth0 is bridging your guest NIC to your physical ethernet card on your host machine, but what NIC is eth1 supposed to be bridging? firewire network? wireless network? or the same NIC as eth0? I'm guessing its actually a bridge to your firewire or wireless which would put it on a different physical network(which is down) hence why its not getting a leased IP and this network is probable inactive.



  • actually the problem was one of PEBCAK... i needed to powercycle the modem. EL OH EL.

    Yeah, i'll be doing a write-up of how to get this working (i have 3 physical NICs on my computer, 2 wire, and 1 wireless); i found out about disabling all protocols after posting here, i did that, and it still wasn't working, so i thought "great, FAIL!"

    But it's working like a charm now, 1 gig flat VMDK and 64 megs of ram. That's better than a regular "software" solution. Not only that, but all of the mysterious "network" issues we'd been having for the past 4 months disappeared. Hardware routers are crap unless you spend the money and get one that actually runs an OS (like cisco).

    Anyhow, all computers on the network can lease IPs from the vmwareplayer running ipcop, and grc.com's shieldsup displays as it should. perfect perfect perfect! 



  • HOW-TO guide (up and running in less than 20 minutes with two physical NICs) posted HERE (dslreports forums)

    Thanks for bothering to read my plea for help! 


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.