Ahh, the corporate life...



  • Instead of a holiday bonus this year, my company did this for us:

    Two weeks before the deadline (just before Christmas) they sent an email with a very long obscure subject line that told us there was a CBT (computer based training) for our timecard system, and that we'd have a new way to log into it.  (Note that's all it said, it didn't warn us of the things below.)  I and many of my coworkers misplaced the email and promptly forgot about it.  So, we come in one day last week to find that the timecard system is offline, but it has a nice forwarding link to the new one.  The new one's login screen is identical to the old one.  But my login credentials don't work.  I try a few variations and after the 3rd or 4th one, finally get a message that tells me that we no longer have to prefix our usernames with "1000000".  (A WTF by itself, so it won't be missed.)

    Fine, I enter it that way, but my password still doesn't work.  I give up after 4 tries, because they lock you out at 5.  I figured I'd just wait until some coworkers came back to work because I knew this was going to be bad.  We're supposed to enter our timecards daily, but I'm passive-aggressive enough to refuse when they bollux the system.  Anyway, a coworker tries it, fails, asks me if I can get in, and then calls support.  They tell him (and then he tells me) what the new default password is.  They insist that an email went around, but neither of us remembers it.  A few days later when the vacationers came back, I overheard that alot of THEM didn't remember the email either.  I finally found it again this week.  In the email, it says that if you mouse-over the password field, it will tell you the default password.  I guess they thought that would be intuitive, but I sure never thought of doing that.

    Anyway, the WTF's get better, hang in with me.

    Finally get into the system to discover a completely blank database.  It's looks identical to the old system, but no previous timecards are there, and none of the account numbers I used to charge my time to are there.  The old timecard system had a "template" feature which most of us kept our numbers in, and since it was there, we didn't think to keep them listed anywhere else.  So we all had to go back through email archives and other paperwork to find the numbers for the projects we're working on.

    But wait...

    The numbers don't work in the new system.  They provided a translation utility in a particular intranet web page (once you found it).  Also, someone showed me that you can translate the numbers directly in the timecard system.  You have to search with the first 4 digits of the old number and it will bring up a list of matches.  I tried using a whole number and it refused to display any matches.  So, first 4 digits and select from the list.  The reason this search works is that instead of keeping the same account name between old and new numbers, they've set the account name of the new number to be the old number.  So when we look at our timecards all filled out, they're full of meaningless numbers with no English descriptions.

    HoHoHo  😞



  • This is one of the reasons that I'm happy I'm an independent contractor. This means no timecard apps or the like, I just create an invoice in quickbooks and get paid. A while back I was working for a large contracting firm that used a timecard submission system, an old asp/vb web app rife with bugs and problems.

    I feel your pain...at least it was just in time for the holidays 🙂



  • @jetcitywoman said:

    if you mouse-over the password field, it will tell you the default password.

    Ah .... Enterprise Security
     



  • We use a timecard/sheet system that actually works. I hate it because it's adminsitrative work and because it's Another Dodgy Web Application, but I like it because it's organized enough and works well for both the people filling it and the ones doing reports.

    I don't know if I should mention it by name yet, given whatever advertising guidelines on this site.

    I'm mentioning it because it may alleviate pain in the corporate world.



  • @medialint said:

    @jetcitywoman said:

    if you mouse-over the password field, it will tell you the default password.

    Ah .... Enterprise Security
     

     For sure.. now we can log in as managment before they get here !



  • I should add the post script for completeness:

     Friday was the deadline for timecard submissions and approvals by our supervisors.  My supe went to approve our cards and discovered that he was no longer authorized.  He called the help desk and was told that only managers at level "X" could now do approvals.  (Basically one level above him.)  So instead of the immediate supervisors doing the approvals, now it was basically dept managers.  In our case, our DM was now responsible for the approval of over 70 timecards.  That's just our small dept, I wonder what some of the bigger ones were faced with.

    Upon further questioning, my supe discovered that the accounting people (had apparently been just as blind-sided as everybody else) and only had time to enter that many managers as approvers.  Apparently they worked top-down, which is logical.  The WTF there is, of course, that they had to hand-enter all the approvers again.  I don't know who was in charge of this system transition, but they managed to screw everybody in the org chart!



  • Is the very same IT dept that remote desktopped into your PC to do windows update?



  • Heh, we're so big that it's not likely the same people.  Same kind of thing, though....  At some point a company gets SO big that it totally trips over itself trying to get anything done. Thanks the the Merger-fests of the 1990's we're way beyond that point.



  • @jetcitywoman said:

    At some point a company gets SO big that it totally trips over itself trying to get anything done.

    And then eventually you get to the point where one part of the company is suing another part, and you realise that the capitalist dream was all a joke in rather poor taste. 


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.