NodeBB Plugin Compatibility / Or how to read a timestamp



  • So, seeing this in the logs:

    {"level":"warn","message":"[plugins/load] The following plugins may
     not be compatible with your version of NodeBB. This may cause unintended
    behaviour or crashing. In the event of an unresponsive NodeBB caused by 
    this plugin, run 
    `./nodebb reset -p PLUGINNAME` to disable it.","timestamp":"2016-11-11T00:55:07.559Z"}
      * nodebb-plugin-upvote-notifications
    

    From the admin control panel:
    0_1480608422215_upload-44cb0122-072b-4aa4-8cfb-446d6a8b1dc3

    From package.json:

    {
      "name": "nodebb-plugin-upvote-notifications",
      "version": "0.2.0",
      "nbbpm": {
        "compatibility": "^1.3.0"
      },
    

    I admit to not really understanding the syntax for the version compatibility strings, but that looks correct to me. For comparison, this one passes the check, apparently:

    {
      "name": "nodebb-plugin-youtube-embed",
      "version": "0.6.4",
      "nbbpm": {
        "compatibility": "^1.0.3 "
      },
    

    What's wrong with the upvotes plugin's compatibility string?



  • Gah. That's old, presumably before the version changed.


  • SockDev

    For caret ranges, only major version must match. Any minor or patch version greater than or equal to the minimum is valid.

    @boomzilla Something tells me NodeBB's check is at fault here

    undefined'd



  • @RaceProUK said in NodeBB Plugin Compatibility:

    Something tells me NodeBB's check is at fault here

    Yeah, no...in more recent messages it passes. I updated the version when they implemented the breaking change for 1.3.0 but before 1.3.0 had been released. 😖 That's what I get for looking at old logs that don't have good timestamps at the beginning of the line.


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.