Wifi requires wrong password before connecting



  • My work laptop is a Lenovo T450 running Windows 7 Enterprise (it also has Symantec Endpoint Protection [antivirus] and Cisco AnyConnect Secure Mobility Client [to VPN into my company's internal network]), and I often use it to work from home. But, my wifi connection on it is kinda wonky, to use the technical term. I can connect fine to the work network, and I'm pretty sure it connects fine to public wifi, though I don't have much cause to work away from both home and office. But on my home network, it asks for my network password, and almost immediately comes back with "Windows cannot connect to this network." So I try to connect again, re-enter my password, and it fails again. It does this as many times as I care to repeat the process.

    I have tried in the past to run ipconfig /release Wireless and ipconfig /flushdns, tried to choose disconnect between when I entered my password and the connection attempt failed, tried connecting to another network nearby (which I don't have a password for, so it fails) and then reconnect to mine, tried connecting to yet another network nearby (which I do have the password for) and then disconnect from that and reconnect to mine, and yet more things. I have also tried netsh winsock reset, which does work, but that requires me to reboot, which I sometimes would like to avoid, having left open programs from my session at work.

    The only things that I had found to work were to keep trying to reconnect until it somehow decided that it could connect, reboot the computer, or this last one, which makes me go "wat?!"

    If I attempt to connect to my home wifi and enter the wrong password, obviously the connection fails. But then I can try again and enter the correct password and it connects immediately. I am inclined to think this is something weird with my work laptop because I have a personal laptop that stays at home (Win7Pro) that has no issues connecting at all.


  • Impossible Mission Players - A

    Not having any real info about your home network, I hazard a guess that it's set to security of WPA/WPA2 PSK/AES. Most older routers tried to keep some kind of dual mode working like that so older devices could connect, and it might be this mode that's causing the issues.

    Nowadays it's standard to have it only in WPA2/AES mode only and everything you have likely supports this (well, unless you have an original Nintendo DS or something like that).

    Changing that should help, and as a side effect will probably make your Wi-Fi perform better overall (not to mention more secure).

    Other than that, you'll need to provide a bit more about your network, since it sounds like it's just your home that has the issue, right?





  • @LB_

    Delete the connection settings and start over.


  • Discourse touched me in a no-no place

    @djls45 said in Wifi requires wrong password before connecting:

    But on my home network, it asks for my network password, and almost immediately comes back with "Windows cannot connect to this network." So I try to connect again, re-enter my password, and it fails again. It does this as many times as I care to repeat the process.

    Sounds like it is trying to perform the handshake with the wireless router while routing the packets over the VPN. That's soooo going to work...



  • @xaade That's a screenshot from my router's administration page. I'm pretty sure that's the entire list of everything it could ever support.



  • @LB_ No, I'm saying, have you tried deleting your computer's "memory" of the wifi connection, and starting over completely.

    I have trouble with my VPN like this too, where it thinks I'm on a different WIFI or something.

    Another thing I've noticed.

    In internet options, my company has a custom configuration script,

    Internet options, LAN settings, configuration file.

    If I untick that, sometimes the problems go away, but I have to retick it if I want access to my corporate LAN address locations (it overrides my hosts file).

    So, while I'm connecting to wifi, and logging into the LAN, I untick it, then retick when the VPN is connected.

    0_1469888590804_upload-48529b15-2ce6-4c92-9591-2da8699ed39b



  • @xaade oh I'm not having the same problem as you or @djls45, I was just asking @Tsaukpaetra's opinion of my router's security settings. Sorry for derailing.



  • I just read the topic title as "Wife requires wrong password before connecting." I don't think I want to know what that means.



  • @HardwareGeek

    Do you guys have a safe word for your safe word?


  • Impossible Mission Players - A

    @LB_ said in Wifi requires wrong password before connecting:

    @Tsaukpaetra
    0_1469879375370_upload-fe49e832-01d2-4da6-b302-f4d5698b243e
    ???

    Yeah, that looks right. Traditionally its set to the one right below it.

    So, how is that Netgear treating you?



  • This reminds me of an SF story I read about 25 years ago. The main character was a "kid." After an accident or something (?), he'd had large parts of his brain replaced with "glass" I think he called it...basically some sort of computer type stuff.

    Anyways...his deal was that he would get to know people very well and would be able to figure out their password. So somehow he managed to get adopted or fostered or whatever by some guy's family. Said guy was some sort of government muckety muck, and someone wanted to be able to get his password.

    So after living with the guy for a while, he figures out the password, and the bad guys use it (I think they also needed a fingerprint or something, but whatever). And are immediately caught. It turned out that whenever this guy logged in, he always used a wrong password first. Of course, the bad guys did not do that, so red flags went up and everyone went to Guantanamo or wherever.



  • @boomzilla So, a behavioral password.

    I have a DDR pad for mine.



  • @xaade Up Up Down Down Left Right Left Right is a poor code btw.

    Filed under: Especially when your password is BAStart




  • Impossible Mission Players - A

    @powerlord said in Wifi requires wrong password before connecting:

    @xaade Up Up Down Down Left Right Left Right is a poor code btw.

    Filed under: Especially when your password is BAStart

    My brother's password is enterable by a numpad and a Nintendo DS gamepad.



  • @Tsaukpaetra said in Wifi requires wrong password before connecting:

    Other than that, you'll need to provide a bit more about your network, since it sounds like it's just your home that has the issue, right?

    My neighbors gave me permission to use their wifi network (before I set up my own router), and it does happen on that one, too. My wireless router is a Linksys E3200 dual-band a/b/g/n router, and I have it configured to provide a separate name for the connections for each of the 2.4 GHz and 5 GHz bands. I'm pretty sure I have it set to WPA2/AES encryption, because I do remember the security thing.

    @dkf said in Wifi requires wrong password before connecting:

    Sounds like it is trying to perform the handshake with the wireless router while routing the packets over the VPN. That's soooo going to work...

    That's something I've suspected, since I can get the same issue if the VPN was still on when the laptop went to sleep or something similar that requires a new connection. But this happens even if the VPN had been disconnected when I try to connect.

    @xaade said in Wifi requires wrong password before connecting:

    @LB_ No, I'm saying, have you tried deleting your computer's "memory" of the wifi connection, and starting over completely.

    ...

    In internet options, my company has a custom configuration script,

    My company does not have a configuration script, so that option is unchecked in my LAN Settings.

    I don't think I've tried deleting the saved network connection and starting over, but I think it would take longer than simply entering the wrong password and then the right one.

    Sometimes the wifi connection won't show up for several minutes, and when it does appear, it shows as having a fairly weak signal strength (one or two bars), even though I've set both the router and the laptop's wifi card to use maximum transmission power. Once it connects, though, the signal jumps up to 5 bars (the maximum), and works great.

    @boomzilla said in Wifi requires wrong password before connecting:

    This reminds me of an SF story I read about 25 years ago. ...

    This sounds interesting, and I should probably find and read it sometime. Tattletale (from Worm) also figured out people's passwords by "getting to know them" ("super-inference") in her flashback-background (flashbackground?) chapter.



  • @boomzilla
    0_1469943825391_upload-2f5716a4-d14c-47bc-93d7-03ecc0d5e152

    but it just needed some Chuck Norris ...



  • @djls45 said in Wifi requires wrong password before connecting:

    Sometimes the wifi connection won't show up for several minutes, and when it does appear, it shows as having a fairly weak signal strength (one or two bars), even though I've set both the router and the laptop's wifi card to use maximum transmission power.

    There are an awful lot of Windows wifi drivers with broken support for the chips' power-saving features. Diving into the wireless interface's configuration settings and turning off "Let Windows turn off this device to save power" fixes loads of this class of problems, in my experience.



  • @flabdablet said in Wifi requires wrong password before connecting:

    @djls45 said in Wifi requires wrong password before connecting:

    Sometimes the wifi connection won't show up for several minutes, and when it does appear, it shows as having a fairly weak signal strength (one or two bars), even though I've set both the router and the laptop's wifi card to use maximum transmission power.

    There are an awful lot of Windows wifi drivers with broken support for the chips' power-saving features. Diving into the wireless interface's configuration settings and turning off "Let Windows turn off this device to save power" fixes loads of this class of problems, in my experience.

    Good to know. 👍 I have just disabled this setting, so we'll see how it goes.



  • @anonymous234 said in Wifi requires wrong password before connecting:

    @xaade I just use a Guitar Hero controller

    I remember GH3 had cheats which were just some 15-note sequences of notes and chords. Quite a bitch to enter, and since "unlock all songs for Freeplay" was pretty necessary to enjoy the game...



  • @djls45 said in Wifi requires wrong password before connecting:

    Sometimes the wifi connection won't show up for several minutes, and when it does appear, it shows as having a fairly weak signal strength (one or two bars), even though I've set both the router and the laptop's wifi card to use maximum transmission power. Once it connects, though, the signal jumps up to 5 bars (the maximum), and works great.

    That sounds suspicious.

    Interference...

    Try moving the router in the house.



  • @xaade said in Wifi requires wrong password before connecting:

    @djls45 said in Wifi requires wrong password before connecting:

    Sometimes the wifi connection won't show up for several minutes, and when it does appear, it shows as having a fairly weak signal strength (one or two bars), even though I've set both the router and the laptop's wifi card to use maximum transmission power. Once it connects, though, the signal jumps up to 5 bars (the maximum), and works great.

    That sounds suspicious.

    Interference...

    Try moving the router in the house.

    There probably is interference, but I can't move the router, because it's in a small closet.


    My work laptop has decided it will not get internet access under any circumstances. It can connect to the wifi fine now, but it doesn't show as having internet access, nor does any browser access any webpages.

    Could having the wifi router set up as a DHCP server cause such problems? The modem is also a DHCP server, and my neighbor's wifi router is also a DHCP server, and both wifi routers are connected to the modem with Ethernet to one of their LAN ports. Are there issues that could be fixed by disabling the DHCP server setting in the routers and connecting the modem to their WAN ports instead?


  • BINNED

    @djls45 so wait... You basically have three DHCP servers on the same network?

    Yeah... Turn everything but the modem one off, otherwise it's a world of undefined you're going to experience.


  • Discourse touched me in a no-no place

    @djls45 said in Wifi requires wrong password before connecting:

    Could having the wifi router set up as a DHCP server cause such problems?

    That depends on how the NATting is done, but yes. If the actual gateway to the outside world isn't ending up as the default route, stuff won't work. It's a really bad idea to have multiple DHCP servers on the same network unless they serve identical information; otherwise you get a race to see which responds first, and the one that wins is usually the one that isn't also busy really routing packets to somewhere useful…


  • BINNED

    @dkf said in Wifi requires wrong password before connecting:

    It's a really bad idea to have multiple DHCP servers on the same network unless they serve identical information;

    Which you likely can't even do properly just using consumer-grade hardware that's likely used here so... yeah, fire, kill with.



  • @djls45 said in Wifi requires wrong password before connecting:

    It can connect to the wifi fine now, but it doesn't show as having internet access, nor does any browser access any webpages.

    I've started hearing lots of reports of Windows 10 doing this to people. Have yet to get my hands on an afflicted box to track down the cause.



  • @dkf said in Wifi requires wrong password before connecting:

    It's a really bad idea to have multiple DHCP servers on the same network unless they serve identical information

    Even then it's a really bad idea to have multiple DHCP servers on the same subnet unless they're fully aware of each other, which the simple ones inside consumer routers and modems are highly unlikely to be.



  • @flabdablet said in Wifi requires wrong password before connecting:

    I've started hearing lots of reports of Windows 10 doing this to people. Have yet to get my hands on an afflicted box to track down the cause.

    I had it happen recently - I hadn't used wifi in a while (turned it off). Then I needed it. Just wouldn't work. Turns out the wifi connection had been bridged. I blame HyperV. Broke the bridge and all was good.



  • @djls45 said in Wifi requires wrong password before connecting:

    Are there issues that could be fixed by disabling the DHCP server setting in the routers and connecting the modem to their WAN ports instead?

    Either/or; not both.

    If you connect your routers' WAN ports to your modem, then you'll typically be adding another layer of NAT at the router; even if you're not doing that, you'll be creating a subnet for each router's clients that will be separate from the subnet between the router and the modem.

    DHCP is a broadcast-based protocol, and broadcasts don't cross routers. So if you reconfigure your routers as above and turn off their own DHCP, clients that connect to those routers won't automatically get IP addresses assigned to them; the upstream DHCP server inside the modem will be visible only to the WAN ports on the routers.

    Assuming the only reason you have these routers is to provide wifi service on your LAN - that is, assuming that what you actually want to create is a single subnet with all your (and your neighbor's) Ethernet and Wifi devices visible to each other and able to access the Internet using the modem as their gateway - then what you need to do is turn off the wifi routers' routing brains and set them up as straightforward WAPs. This is the simplest configuration that could possibly work, and it means that the only routing device whose settings you then have to worry about will be the one built into the modem. Also, all connected clients (including the WAPs, unless you configure them with static IP addresses which is probably a good idea) will then be in the same subnet, able to read and write broadcast traffic to that subnet, and will therefore be able to get IP addresses from the modem's DHCP server.

    Better routers will have explicit settings that let you do this, after applying which you will find that the WAP's WAN port works just like another LAN port. If you have shit-grade wifi routers, your best bet is simply to turn off their own DHCP and wire them to the modem via one of their LAN ports.

    If you actually want you and your neighbor not to be able to see each other's devices on the same LAN subnet, that's when you'd use the configuration with a separate wifi router for each household, each connected to the modem via the wifi router's WAN port and all three devices running their own DHCP servers. The routers would then pick up IP addresses for their WAN sides from the modem's DHCP server, and clients in each building would get IP addresses from the DHCP server inside that household's wifi router.

    If you're going that way, you'd want to connect nothing to the modem but WAN ports from wifi routers.


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.