USB headset feedback Webex



  • So I bought a USB headset a long time ago, but for the longest time it worked fine. Then I find out that for some reason, when using webex only, audio is rerouted somehow such that there's feedback.

    I've even muted my mic (physical button on mic), such that no data is being passed back from my mic to the computer, so I don't think it's the physical mic, I think it's a software bug. (Even webex shows no audio input from mic).

    Somehow the software is rerouting the audio from the meeting as microphone input, creating the feedback loop. Hitting the software mute button in webex prevents the audio feedback.

    I haven't tested whether this happens when I also mute the audio FROM webex.

    So something's wonky.



  • We were given USB headsets to use for Webex. Then Webex was configured to not allow the voice to be provided by headsets connected directly to the computer, so that we could be forced to use the same headset with a soft IP phone which worked inside a browser to dial into Webex calls. It's a massive ballache, so everyone stopped doing that, put their Cisco headsets in their drawers and went back to using normal phones.

    That's right... USB -> computer -> Webex was disabled so we could go USB -> computer -> browser -> server -> phone call -> Webex.
    :headdesk:



  • Sadly, although I use WebEx for meetings twice a week, we're not issued headsets so I'd have to bring my own if I wanted to use it... so I just use my office phone.



  • Oh, as this is General Help...

    I'd go through the audio control panel disabling the devices one by one until it stops. If the only device enabled is the headset and it does it, then try another headset.



  • Ok, when I use the test audio feature, while they are talking, the mic volume bar reports the audio as microphone audio.

    :wtf:


  • :belt_onion:

    Is that KDE?

    I had the same freaking thing recently with a regular headset too, might be a Pluseaudio or Phonon bug? Had to take the mic volume way down for it to stop echoing in my headphones.



  • And the bug fixed itself after opening and closing test audio several times.

    :wtf:

    Well, at least I have a workaround.



  • @Onyx said:

    stop echoing in my headphones.

    No, it's echoing over the meeting.

    They're hearing the feedback too, because it's taken as mic input, and casting it to the meeting too.


  • :belt_onion:

    @xaade said:

    And the bug fixed itself after opening and closing test audio several times.

    :wtf:

    Well, at least I have a workaround.

    If I wasn't wrong about KDE there, I kinda suspect Phonon. I just remembered that I tried switching to ALSA in TeamSpeak and it was still doing it. That, combined with your fix... yeah, probably Phonon.


  • Impossible Mission Players - A

    Almost sounds like the WebEx is also piping in Stereo Out Mix as input...



  • That's a good way to describe what I'm observing.

    Which would naturally create a feedback loop, but since there's a delay due to the connection, it sounds like a whooping cough.



  • It's obviously a bug in Webex, not sure what you expect to be able to do about it.

    EDIT:

    @Onyx said:

    Is that KDE?

    Oh. Color me unsurprised.



  • Add that to the bug list then.

    I love this one.

    If you try Chrome on Windows 10, it says Windows 10 is not supported.
    But if you try IE on Windows 10, it works.

    It's because Chrome isn't passing an OS version that Webex will parse, and instead of saying Chrome on Windows 10 isn't supported, they just say Windows 10 is not supported.

    Screenshots tomorrow if the error is still there. (I have to wait until the meeting is open again).



  • @xaade said:

    So I bought a USB headset a long time ago, but for the longest time it worked fine. Then I find out that for some reason, when using webex only, audio is rerouted somehow such that there's feedback.

    I'm not sure if it's the same problem or not, but I've found that on the PC I use for work, when I use generic headphones and the built-in (webcam) mic for phone calls, I get loud staticky noise when making a call using Microsoft Lync (Lync 2013, Windows 7 Enterprise on an [URL=http://www.hp.com/united-states/campaigns/workstations/images/datasheet_8570w.pdf]HP EliteBook 8570w[/URL].) No such problem when calling using Skype or Aastra BlueStar (our softphone app.) And no problem when using a USB headset.

    I eventually figured out that it's being caused by the [URL=https://en.wikipedia.org/wiki/Comfort_noise]comfort noise[/URL] that Lync injects into conferences. It is somehow getting fed back into the "audio enhancement" feature of the laptop's sound card, causing it to get amplified to the point where it drowns out your actual conversation. There was no problem with Skype or Aastra because they don't generate comfort noise. And the USB headset's driver has no audio enhancement features.

    I was able to dig through the Windows device manager, locate the driver for the sound card and disable audio enhancements. This keeps the comfort noise down to background levels, where it is supposed to be. Sound played through the built-in speakers sound tinny, but I'm willing to put up with that.

    I don't know if this will apply to you, since you're using a USB headset, but I would check to see if there are any kind of audio enhancement features in its driver. If so, try disabling them and see what happens.



  • Will do. And will update if that's it.

    For some reason displaying and closing the audio test in Webex solves the problem, so it's probably not a system or driver level problem. But could still be so.


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.