Oracle: "Your gcc isn't configured to create executables."



  • Because executables need oxygen?  I think he doesn't quite understand what optimization is for.
     



  • i wouldn't really call this a WTF, just a common error on MiniGW



  • The wtf is that the Oracle person thinks it can be solved with -O2.



  • @arty said:

    The wtf is that the Oracle person thinks it can be solved with -O2.

    This is a standard autoconf test. It tries to compile a trivial C file using the current compiler config, to make sure that config is sane. If it's not sane, the test fails, and you must study config.log to understand why.

    If CFLAGS was set to "-O2 -g -fumble", the test would fail, and config.log would contain gcc bitching about the unrecognised '-fumble' option. So setting CFLAGS to something sane could possibly fix it.

    Of course, the right answer is just "read config.log for the real error message". But as wrong answers go, it wasn't actually a stupid one.
     



  • I see your point.  I wasn't really thinking of -O2 as an alternative to anything so much as a random stab at "configuring gcc to produce exectuables".  But the Oracle guy might be just as well be using it as an alternative to explaining how to unset CFLAGS.  Sorry for the bad WTF.
     



  • His reasoning behind changing the CFLAGS is still missing.  I wouldn't have immediately guessed that manually setting CFLAGS to -O2 was meant to override a bad CFLAGS.  He merely said that it wasn't setup to produce executables (without saying what would be causing this).

    Though the solution may work, giving anybody an obscure solution to a problem they will likely face again without any explanation as to how they are fixing the problem is a WTF.  Unless you are a consultant--then it's job security. 


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.