VC++ 2013 - how to make enter key work in IntelliSense?



  • When autocompletion pops up, hitting enter makes new line instead of completing word, since the popup didn't get proper focus. Very annoying. I googled a bit and found there is "Toggle Completion Mode" thingy that fixes it, but it's disabled in C++. Is there another way to make it work like it should?


  • Winner of the 2016 Presidential Election

    Hitting down should give the popup focus so enter will work, or tab will autocomplete it.
    Why is it disabled for c++ though?



  • @Jaloopa said:

    Hitting down should give the popup focus so enter will work, or tab will autocomplete it.

    I'm not saying it's not functioning. I'm saying it's extremely unconvenient for me. Broken in the Blakey sense.

    @Jaloopa said:

    Why is it disabled for c++ though?

    Because the other completion mode does more things than just make enter work like it should, and the "more" part is incompatible with C++. Or something.



  • Ctrl+space will change this AFAIK



  • Once.



  • Ah. I remembered it as a toggle.



  • You probably confused it with CtrlAltSpace. Which is just shortcut for toggling completion mode I mentioned in OP. Which is disabled in C++.



  • Is ctrl+space very inconvenient for you? It's become such a habit for me I hardly even notice it.



  • It became more convenient when I disabled "automatically show autocomplete when I write" - now, I don't get false visual clue and don't mistakenly hit return anymore. Still, I'd prefer if I didn't have to hit ctrl+space every few seconds.


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.