Newbie - trying to publish to my spamhole



  • I have downloaded the personal website starter kit and have followed
    the instructions provided by [spamspamspamspam.com][1] for "creating an asp.net 5
    personal web site", but its still not working.
    I think there is an error in my web.config file and below is the debug message I'm getting when I try to run the site.

    Line 5:  	Sub Application_Start(ByVal sender As [Object], ByVal e As EventArgs)
    Line 6:  		AddHandler SiteMap.SiteMapResolve, AddressOf Me.AppendQueryString
    Line 7:  		If (Roles.RoleExists("Administrators") = False) Then
    Line 8:  			Roles.CreateRole("Administrators")
    Line 9:  		End If
    

    Source File: C:\Documents and Settings\aysel\My Documents\Visual Studio 2005\WebSites\aysellsView\global.asax Line:
    7

    The instructions I followed from http:/ /spamspamspamspam.com


    Mod - PJH: Re-inserting URL since TL0's can't post them.
    Mod - bz: Sabotaging URL because I suspect spam. Waiting and seeing...
    Mod - bz: Anonymized this spammer and edited out the spammy site



  • Abused my mod TL3 powers to move it to appropriate category.

    What's the actual error? All we have is a line, and seemingly an innocent one. Do you have a proper Imports statement there? Does it run on your PC?


  • mod

    @Maciejasjmj said:

    seemingly an innocent one

    There's a single equals (assignment) instead of a double equals (equality comparison). I bet that's the problem.

    @Alexia_Pamelov, have you tried If (Roles.RoleExists("Administrators") == False) Then
    Nevermind, this appears to be VB.



  • Wrong bet, welcome to VB. = means both here.


  • area_deu

    @Yamikuronue said:

    double equals (equality comparison)

    WRONG!
    That is VB.NET. It doesn't have "==".


  • mod

    Oh, this is VB codebehind? That'd be a good thing to note in the OP. Withdrawn then.


  • sockdevs

    It'd be good to know what exception is being thrown… if one is being thrown, that is…


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.