Skyrim Mod Reviews or something I guess I got insomnia



  • Falskaar

    The good:

    • Sizeable area (approximately 2/3rds or so the size of Solstheim, but with maybe 1/3rd of the explorable locations
    • Decent length of main quest
    • Decent number of side quests
    • Everything's voiced
    • Nothing outrageously ridiculous regarding the setting (no spaceships or super-mega-killer-twink-swords or anything).
    • Installs and uninstalls clean on existing save files (although this is Gamebryo, so don't trust it completely based on just my word.) Compatible with other mods, and I have about 40 or so installed. Uses almost entirely stock leveled-lists, meshes, and textures.

    The bad:

    • Rows of grass/other ground clutter arranged in unnaturally straight lines. Unnaturally-shaped landscape.
    • The voicework is... well most of it is acceptable. Unfortunately the main dude you follow instructions from has a pretty bad voice actor, and you can't help talking to him often.
    • Occasionally the voice levels will change dramatically-- for example, one line of dialog will be half the volume of the line before and the line after for absolutely no reason at all. (The "normalize" command in Audacity is pretty easy to use, guyz.) The ending cutscene dialog for some reason is not only super-soft, but also ignores my subtitles setting and so I had no idea what the dude was saying. (It was some kind of Fallout III-esque wrap-up slideshow. I guess.)
    • The story is kind of ... well it's not as bad as the Thieve's Guild in the base game, but then again, few things reach that level of shitty writing. The McGuffin was said to turn the island warm and temperate, then said to produce immortality(?), then when actually encountered it did neither of those things (and what it did do made no sense). The Jarl does something so incredibly stupid at one point, it had me cringing.
    • A very long combat sequence followed by a literally 5+ minute unskippable cutscene followed by another very long combat sequence-- and there's no autosave point after the unskippable cutscene. Even Morrowind wouldn't pull that kind of shit.
    • Speaking of which, the ending combat sequence took, I swear to Christ, hours to legitimately complete. I actually got bored at some point and turned on god mode and skipped it. I think he only tested the mod using "Novice" difficulty, because at any reasonable difficulty it's tedious as hell. During portions of it, you are fighting mooks who aren't wearing any uniforms and it's nearly impossible to tell the mooks apart from your 5 allies.
    • A couple of the explorable locations (and there weren't many to begin with) were empty or inaccessible. The inaccessible location had nothing in or near it to begin the quest to access it. (Assuming there is one. I uninstalled before I found anything pointing there.)
    • I would have appreciated at least one new enemy type, or one new armor type.

    The summary:

    Actually pretty decent for a volunteer effort. Per usual with all volunteer efforts, the biggest flaw is lack of polish, and the inability to recruit good voice talent. The only major game design issue was the length of the ending fights, other than that the quests were solid and decently-written.



  • Wyrmstooth

    HOLY SHIT THIS MOD IS PRETTY AMAZING, Jesus I'm not kidding, this is one Bethesda could easily sell for $15, digging it. Still no new enemies, but new ingots, alchemy ingredients, variants of Draugr, dragon skins. The final boss battle is both challenging (in a way Falskaar's wasn't) and short (in a way Falskaar's wasn't). The voice work is excellent with only a few sound level hiccups, which very well may be due to game engine bugs. Tons of explorable locations, natural-looking landscape (including new types of ground clutter.)

    Basically uninstall Falskaar, keep Wyrmstooth.



  • @blakeyrat said:

    Falskaar

    I just did the first quest again since I started a new save when I bought the DLC.

    The first thing you see when you start the quest that starts this mod is a torch that emits no light until about a second after you go around the corner. Later in that dungeon, there's a quest objective that goes something like "figure out a use for the strange object" which would be a great quest objective if they didn't put a giant arrow pointing to the place you're supposed to put it a few feet away from you.

    You go through a "portal" (actually just a stone wall with some glitter on it - see Dawnguard for the correct way to implement portals) and get to a really boring room where you are incapable of moving or pulling out your weapon. You talk to a guard and are forced to agree to help him after about 50 lines of dialogue.

    Then you go into another dungeon, full of bandits. You kill the bandits and go to a room with no bandits in it. You have to unlock a cage door, except that the cage door isn't locked and using the "Open" command that looking at the door brings up does exactly nothing. The guard opens the door using some kind of cheat codes and then the guy trapped inside comes out, talks for a bit, then walks back into the cage and waits for a few seconds before running out of the dungeon, stopping at each bandit corpse to yell "HOW COULD THIS HAPPEN?" When you get to the exit of the dungeon, the exit (which is the same as the entrance) is glowing purple even though there is nothing that glows purple anywhere in the content you've played so far.

    You go to the town after passing through another magical only-openable-by-guards gate. There are no wild animals on the way there. It's just you, your follower, and a bunch of trees and lines of grass tufts. The guy you rescued talks to his dad, who has the slowest speech I've ever heard. It takes him about a minute to say each sentence. You go to the Jarl and he's talking to his son in the cheesiest way possible. You tell him about the guy who was taken by bandits and he says to go to the church. You go outside. Then you see this:



  • @ben_lubar said:

    You go through a "portal" (actually just a stone wall with some glitter on it - see Dawnguard for the correct way to implement portals)

    Fuck Dawnguard, Shivering Isles knew portals:

    Shivering Isles Walkthrough - A Door in Niben Bay - Strange Door – [05:15..05:50] 05:50
    — RE4freak4

    But yes, your summation of the quality of Falskarr is spot-on. Especially when contrasted with Wyrmstooth which does everything right.



  • Falskarr part 2. But first, a visual aid:

    The Jarl (town 1) tells me to go to the church. Obviously it's far away so I need to buy a horse since there's no way I could have brought a horse to a new island. I ask around the town and the two full stables and everyone says something along the lines of "there's only one guy who owns a horse, and he's at the inn". Fuck that guy. I walk all the way to the church.

    The guy at the church says he can't help me. I walk all the way back.

    The Jarl says that I should talk to some people at a dock because they know about bandits. I walk down the only path that goes down the 500,000 foot cliff in the middle of the island.

    A guard is lying on the ground near a burning cart. The guard says he was attacked by the bandits that were attacking a cart that he went to go help the people from but they were already dead. What? Anyway, I give him a weak healing potion because apparently his health doesn't regenerate out of combat. He stands up abruptly and tells me to go away.

    Anyway, going to the docks.

    I walk to the docks. Suddenly, there are bandits attacking me. I get a quest to kill them from an invisible quest giver. I rescue the people at the docks who are tied up with invisible ropes and still holding their weapons. I ask the guy I was supposed to ask about the bandits. He says I can take the boat but only if I pay him 500 gold. I try that but it says my 20k gold is not enough. He also tells me that the bandits are on the opposite end of the continent. I walk all the way past the burning cart (where the injured guard and all the corpses and blood splatters were but now there's just the cart) and go to a bandit castle. I go into the castle and walk forward, taking the obvious path to the end. I end up back at the entrance.

    I try again, and this time I get to a room with a piece of paper on a table. Also, there's a random suit of dwarven armor on the ground. I grab the piece of paper, which says that the bandits should do bandit things. Then I unbar the door on the side of the room and walk through it. I am now in a cave. Even though I walked down at least three flights of stairs on my way here, the light coming in from a low-polygon-count hole in the cave ceiling is only about 3 feet up. I walk through the tunnel and end up in front of the bandit castle.

    I go back to the Jarl (town 1) and he does his best Vlad impression while telling me to go get his housecarls -- for the non-Skyrim players around here, those are like personal bodyguard-servants -- from their house 50 miles to the north. I walk all the fucking way there.

    Their "house" consists of two walls and two giant holes. They are wearing the same hide armor as the Jarl (and also the same hide armor that the lowest level bandits wear). I tell them that the Jarl wanted them and they say they'll go fight some guy right away.

    I walk back to town 1. The Jarl is standing in the middle of a street talking to some guy wearing fur-trimmed armor painted black. The entire suit of armor had been dipped in a vat of black paint. The guy is apparently the Jarl of town 3, which I haven't seen on the map yet. He wants to search the town. the Jarl of town 1 says he can't. The two people from the two-walls-and-a-roof-with-some-beds-in-it walk up from the south. Somehow. They talk to the guy as he leaves. I didn't catch what they said because it was outside of caption range. They talk for about 20 minutes to Jarl of town 1. Then a priest comes from the north road. He says the guy asked to search the church and they agreed to it and then one guy didn't want them to but he got killed by bandits. The dialogue is spoken in his "indoor voice" except for the last line which is spoken in his "I am in the process of eating the microphone this is recorded with" voice. They all say that town 2 has to be warned and then immediately chicken out. They send me. I walk all the fucking way there.

    On my way there, I hit the Jarl of town 3 with a sword. He silently kneels, then stands up and walks away without talking. It is noon. I reach town 2's gate. The guard tells me I can't come in because the city's on lockdown. I tell him I want to come in. He opens the magical npcs-only door and then walks to the Jarl's house. I walk backwards because I want to watch the gate. Along the way, there is a woman with a sword standing in an empty plot of grass. She has no dialogue. Many of the houses have windows that are mostly embedded in the ground. I get to the Jarl's house and nobody has closed the gate. The guard goes into the Jarl's house.

    I go into the Jarl's house. There is nobody inside except the Jarl, standing near a wall. He tells me that he put the city under lockdown because bandits were attacking. There are 2 minutes of silence where the Jarl is not able to be interacted with. The guard comes into the house and walks slowly up to the Jarl. The guard says that the gate has been breached. I go out of the Jarl's house. It is midnight. The town is on fire. Well, when I say "the town is on fire" I actually mean "flat animated fire gifs are on the town". I jump off a cliff after the Jarl and the guard jump off it. We get to the gate. The gate has been closed, removed from its hinges, slightly shrunken, and rotated by the bandits. We can't go through it because that would mess up the "flow" of the "story".

    The Jarl tells me to go into the catacombs. We go to a gigantic blank wall with a metal door on it. Apparently someone has built Nordic ruins under town 2. I enter after the Jarl and his guard. I walk forward. There is an unlocked door that cannot be opened. I walk back to the entrance. The guard tells the Jarl that he has to go do something. The guard leaves. The Jarl runs directly into me and yells "be careful". The Jarl walks up to the unlocked door and it opens. We go through the Nordic ruins and are attacked by exactly one bandit. The Jarl walks up to a wall. The Jarl does the animation of pulling a lever. The Jarl turns 90 degrees so he is facing parallel to the wall. The handle on the wall does the animation of being pulled. The Jarl sways from left to right a few times. The wall opens. The Jarl walks through. I follow. Inside is an orc and a podium behind a wall with a crack in it. To my left is an unopenable unlocked door. The orc is immune to my attacks and talks about stealing a key or something. The Jarl unlocks the door to the right. I exit the Nordic ruins through a door mounted diagonally with water pouring through it.

    The Jarl tells me to jump off the cliff into the pond below. I do so. Skyrim crashes to desktop.



  • @ben_lubar said:

    The Jarl tells me to jump off the cliff into the pond below. I do so. Skyrim crashes to desktop.

    That exact thing happened to me! Haha.



  • Falskaar part three!

    After restarting the game and jumping into the pond again, I walked all the way back to town 1. I had to use console commands to get my housecarl back since she was stuck on top of the cliff with the Jarl of town 2. Anyway, here's a video of the next part because I can't explain how terrible it is with words.

    Falskaar Cutscene: Warning Valfred – 07:39
    — Ben Lubar

    I walked to the mansion. Again, I didn't meet a single NPC on the way there. I got to the mansion and had to wait 12 ingame hours before the housecarls of the Jarl showed up. We went inside and it had been half-assed by the level designer looted by bandits. We went to a cabinet that was the same shade of brown as everything else in the house. One of the housecarls used a key to unlock the cabinet and we went to the similarly-brown room on the other side.

    After a loading screen, we were in a Nordic ruin. Which was under the house or something. We went down 3 very long, very linear hallways with bandits in rooms between them. Then we got to the end and apparently someone had stolen the key. There was a bandit there that talked with the housecarls for a bit and then one of the housecarls said something like "see you in heaven" and the bandit said something like "what? NOOOOOOOOO" and then there was a 5 second pause and then the housecarl killed the bandit.

    We went out through a door in the room at the end and ended up inside the mansion. Somehow. I had to walk halfway across the continent for a cave or something.

    I got to the cave, and had to wait 4 ingame hours for the two people who had just exited the mansion at the same time as me to get there. I went inside and killed three or four bandits. I got to a room with a quest marker in the middle of the floor.

    One of the brothers kept repeating "did you get the key yet?" or something and the other one said something along the lines of "you should find the key". I'm not sure. Eventually I found it. I'm assuming you all know what a key looks like. This looked like a miniature fried egg on a string.

    I walked all the way back to town 1 and the Jarl had another 7-minute meeting cutscene. They said something along the lines of "we have three keys now but they only have two but we can't get their keys because stealing is wrong".



  • There is one thing about this I don't understand: [spoiler]Why are you still playing it, instead of saying "B*****m it," and uninstalling it.[/spoiler] Good grief, that's awful.


  • SockDev

    @HardwareGeek said:

    There is one thing about this I don't understand: Why are you still playing it, instead of saying "B*****m it," and uninstalling it. Good grief, that's awful.

    if i had to guess for the same reason why i keep playing Mass effect 2 and 3 given blakey's objections to the games.

    either that or it's fun to complain and one always needs new material...


  • Discourse touched me in a no-no place

    @HardwareGeek said:

    There is one thing about this I don't understand

    You're asking this about a guy who plays Dwarf Fortress?

    I shouldn't pick on the game--I played it a bunch right before they started adding the 3D interface, and I was getting decent at it, at least as far as making 2nd and 3rd-tier workshops, stuff with levers and whatnot for flooding chambers for underground farming, and stuff.


  • SockDev

    they added a 3d interface?

    is it any good?


  • Discourse touched me in a no-no place

    @accalia said:

    why i keep playing Mass effect 2 and 3 given blakey's objections to the games.

    Huh. I did NOT expect a onebox there. You'll still have to click through to read the image.


  • Discourse touched me in a no-no place

    @accalia said:

    they added a 3d interface?

    I only tried it around the very first time it was added, probably in 2007? It was a very basic thing, more like a holoprojection, of white boxes showing the outline of your base.


  • SockDev

    @FrostCat said:

    Huh. I did NOT expect a onebox there. You'll still have to click through to read the image.


  • Discourse touched me in a no-no place

    Those are not nearly as funny as the version I provided. Which a link to has been in my signature for like 10 years on another forum. Which I logged in to today for the first time in ages, only to see those bastards at imageshack deleted the userbar I created in probably 2004.


  • SockDev

    yeah. true.

    much shame has been placed upon this one for the lack of funny.

    this one will now spill this one's own blood to appease the ancestors ans wipe this stain from our family.

    /me takes a miniature katana out of the pencil case and uses it to make a small cut in my pinky so that a single drop of blood wells out.

    there. that should be enough to satisfy my ancestors.... now where'd i put the bandaids?


  • Discourse touched me in a no-no place

    :frystare:


  • SockDev

    what? did i not sell it?

    my timing was still off?

    @zoidberg's funnier than I am?

    what?!


  • Discourse touched me in a no-no place

    @accalia said:

    @zoidberg's funnier than I am?

    Did you forget who started this topic? 🙂


  • SockDev

    briefly. good to know the topic filtering is still working.


  • Discourse touched me in a no-no place

    @accalia said:

    good to know the topic filtering is still working.

    The idea that it might suddenly stop, and what that implies about the code behind the bots, amuses me.



  • @FrostCat said:

    You'll still have to click through to read the image.

    I wanted to "like" the last panel of that, but I'll have to "like" you for posting it here.



  • Ok so I finished Falskaar. I'm gonna spoiler this one because [spoiler]why not[/spoiler].

    [spoiler]I get told to go into some dwarven ruins or something so I'm like whatever and I go to where they told me to go. Inside the cave is a word wall with no words on it. Long story short, when I get to the end of the dungeon, there's a book I'm supposed to get. And the same kind of machine that I used during the quest to get the elder scroll (dragon). Except it doesn't do anything and there's no way to operate it.[/spoiler]

    [spoiler]So we get back to town 1 and SURPRISE the bad guys kidnapped the Jarl's wife and son. They somehow know exactly where they are so we go there and rescue them. At some point we split up and I go up a ladder to an area with only one way in or out - the ladder. Somehow the orc guy from earlier is there, so I kill him before he kills me. Of course, there's a 3 minute unskippable cutscene in which I can't control my character while he talks to me before that.[/spoiler]

    [spoiler]I go back to the Jarl and he gets the brillant idea to kill everyone in the fortress because I killed the orc guy. So we go outside and kill about 100 soldiers. The unarmed wife goes through the door first for some reason. Maybe she wanted to punch all the soldiers to death. I dunno.[/spoiler]

    [spoiler]We get to the exit and the screen goes blank. About fifteen seconds later, it slowly fades in over five seconds and we're exactly where we were, except the evil guy is on a horse and has a bunch of soldiers with swords. He tells the Jarl that it would be a good idea to give him the 5 fried eggs on strings because that would make him less likely to kill us or something. The Jarl stupidly gives away the five items we didn't want the guy to have, and the bad guy tells his soldiers to kill us. I get the objective to help fight off the soldiers, but I decide not to because everyone is marked as essential anyway so they can't die.[/spoiler]

    [spoiler]The Jarl seems unaware that the reason the bad guy has all five fried eggs on strings is that he handed them over willingly. He says "there's no time to waste!" and then he goes home. I follow him and he tells me that I need to go back to where we were to kill more soldiers. Fuck.[/spoiler]

    [spoiler]So I go back there and fight some soldiers. Then I talk to the guy who's there and suddenly the screen goes black again. It's a 20 minute non-interactive cutscene! After that's over, I get the objective to fight my way to the castle. I just kinda walked up to it while everyone else was fighting.[/spoiler]

    [spoiler]I get into the castle and instantly sheathe my weapon. IT'S ANOTHER FUCKING NON-INTERACTIVE CUTSCENE! The bad guy is there and he explains that while we were rescuing the Jarl's wife, he stole the book that told him the location of the thing or whatever. Then he walks out of the building and there's about five seconds before I can move. I can't open the doors until I kill all the guards for some reason. More of those magic unopenable unlocked doors, I guess.[/spoiler]

    [spoiler]So we leave the building and they talk about stuff but I don't listen because I summoned my spooky ghost horse and rode to the place where the heart was. Along the way there, nothing attacks me at all.[/spoiler]

    [spoiler]When I got inside the temple, everyone who was talking at the building teleported in with me. We go through the "dungeon" with no enemies and SURPRISE! NON-INTERACTIVE CUTSCENE![/spoiler]

    [spoiler]The bad guy's here, but the heart is wrapped in some kind of magical barrier. He has his wizards working on taking it down. By the way, there weren't any wizards in the story up to this point.[/spoiler]

    [spoiler]They get the barrier down and the Jarl of bad ideas asks him to duel. The evil guy's all like "sure, whatever, but I want to duel the dragonborn wearing legendary daedric armor instead of the Jarl who is wearing the weakest heavy armor in the game".[/spoiler]

    [spoiler]Still in the non-interactive cutscene, my character extremely slowly drifts towards the evil guy. Then the cutscene ends and I immediately yell rii vaaz zol, which turns my target into a zombie under my control. But instead of doing that, it makes him do a green thing.[/spoiler]

    [spoiler]I'm not quite sure what happened next because there were no captions and the audio was almost silent, but he went to touch the heart and a sparkly dragon flew past and grabbed him and flew out of the cave. The screen went blank and there was a 5 minute slideshow of scenes from the mod with no audio or captions. Then I spawned inside the inn in town 1 and the Jarl told me that I was a good person or something.[/spoiler]

    [spoiler]Apparently, the heart gives you climate changeimmortalitybeing grabbed by a dragon or something what the fuck even happened.[/spoiler]



  • @HardwareGeek said:

    There is one thing about this I don't understand: [spoiler]Why are you still playing it, instead of saying "B*****m it," and uninstalling it.[/spoiler] Good grief, that's awful.

    I enjoy complaining about awful things just like @blakeyrat does with his video series.


    Anyway, a summary:

    Pros

    • The continent they added is pretty big. It's mostly empty, but if you like exploring, it should provide a few minutes of content.
    • There are a handful of side quests along the way.
    • The content is fully voice acted. Even the bandits have custom dialogue.
    • If you like complaining, this mod gives you plenty to complain about. It's so bad it overflows integers and becomes good. Or something.

    Cons

    • Massive plot holes
      • [spoiler]You need all 5 fried eggs to get the heart, but the Jarl's wife already has one, so we don't need to do anything at all.[/spoiler]
      • [spoiler]After being told over and over that the bad guy isn't to be trusted and that he must never get the fried eggs on strings, the Jarl gives him all five fried eggs on strings.[/spoiler]
      • [spoiler]The heart is first said to change the climate of the island, then to give immortality, but when you get to it, it summons a dragon or something?[/spoiler]
      • [spoiler]The Jarl's guards live in a cabin nowhere near the Jarl's house, and they used to own a mansion, which was destroyed and rebuilt, but not lived in, but somehow able to be raided for the 0 things they kept inside. Oh, and the mansion had a Nordic ruins under it.[/spoiler]
    • Horrible map design
      • There are no wild animals except mudcrabs. The world feels empty.
      • No random encounters - the only enemies you'll find are inside dungeons.
      • Dungeon entrances and exits don't make sense - several dungeons are extremely linear but exit next to where they start or somewhere in the opposite direction from where they go.
      • Light sources in dungeons are generally 3-foot-deep holes that go to the "surface" no matter how deep in the dungeon you are, but there are no such holes visible on the surface.
      • Water flows into several dungeons from places that have no water in the overworld, but almost never flows out.
    • The story is like 60% unskippable uninteractive cutscenes.
      • The main bad guy can't be killed because he always leaves before the cutscene lets me move.
      • At one point, there was an uninteractive cutscene sandwiched between two huge fight scenes with no save point anywhere in it.
      • At another point, there were two uninteractive cutscenes separated only by a fight with one enemy who doesn't die.
    • Unlocked doors are magically unopenable. All the time.
    • The voice work leaves a lot to be desired. See my video earlier in the thread for a representative example of its quality.
    • The rewards for the quests are all small bits of gold. No new items are added by the mod except some painted shields held by guards and the armor the bad guy wears, which can't be obtained.
    • No new enemy types. Pretty much every enemy you fight is a bandit from the base game. Occasionally you fight some town guards who magically appear out of thin air when they're needed for the main quest.
    • Most of my time spent playing this outside of the uninteractive cutscenes was spent walking. Walking to the next quest, walking halfway across the continent to ask an NPC a question that he refuses to answer, walking back to tell the quest giver that the NPC was unhelpful, and so on.

  • kills Dumbledore

    DISCONECRO!

    Skyrim was £2.50 and I have a graphics card that can run it, so I've finally got it on Steam as well as console. Now I want mod recommendations.



  • Ok well first: anything by Arthmoor is amazing. Seriously. EVERYTHING THAT GUY MAKES. (Except perhaps Open Cities, which I avoid because of bugginess.)

    He also maintains (or used to at least) the Unofficial Bug Fixes pack of mods, get those. (I think they're on Nexus, it's been ages since I pulled them.)

    You should install these mods from me:

    http://steamcommunity.com/sharedfiles/filedetails/?id=19681 <- Re-adds the mudcrab merchant from Morrowind; DO NOT CHEAT AND LOOK UP WHERE HE SPAWNS (when you find him there's a map marker)

    http://steamcommunity.com/sharedfiles/filedetails/?id=21741 <- Makes collecting dragon souls more useful, dragon souls you haven't spend on unlocking shouts are used to increase your stats slightly. Up to a limit of 50, which is probably as many as you'll see in an average game anyway. Slightly OP if you grind dragon souls.

    http://steamcommunity.com/sharedfiles/filedetails/?id=21742 <- Same as above, but increase movement speed slightly along with unspent dragon souls. The only reason it's a separate mod is because morons who play Skyrim with a keyboard bitched and whined.

    The rest of my mods kind of suck. If you want a really cheap cheaty mod, there's one there that makes 2-handed weapons fast enough so they're actually kind of slightly fun to play. I might just delete the rest.

    Oh and of course... my best mod: http://steamcommunity.com/sharedfiles/filedetails/?id=66907293


  • kills Dumbledore

    @blakeyrat said:

    Unofficial Bug Fixes pack of mods

    I got the unofficial patch, that seems to be what you're talking about

    @blakeyrat said:

    morons who play Skyrim with a keyboard bitched and whined

    No worries there, I'm playing with a keyboard as God intended

    I also need to say, the Nexus mod manager (and the site, but not as much) is one of the most awful pieces of UI I've seen in a long time.



  • @Jaloopa said:

    I got the unofficial patch, that seems to be what you're talking about

    There's one for the base game, each DLC and the High Resolution Pack (which you should get if you haven't already-- not sure, Steam might pack that in by default now.)

    @Jaloopa said:

    No worries there, I'm playing with a keyboard as God intended

    Die infidel!

    @Jaloopa said:

    I also need to say, the Nexus mod manager (and the site, but not as much) is one of the most awful pieces of UI I've seen in a long time.

    I don't use it, and don't install any mods that require it.



  • @Jaloopa said:

    Skyrim was £2.50

    Ah - good reminder. I saw that on Steam the other day and forgot to buy it.

    Won't get round to playing it just yet but at least got it while it was cheap. Got the pack with the discounted DLC too.


  • kills Dumbledore

    @blakeyrat said:

    Die infidel!

    Brainfart there. I meant controller


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.