Your date format must be Day/Month/Year (MM/DD/YYYY) to use this file...



  • I found this one rather amusing...

    http://www.nba.com/heat/schedule/outlook_download_0607.html

     

    PLEASE NOTE: Your computer settings must be Day/Month/Year in order for the download to work properly. To check go to -- CONTROL PANEL -- REGIONAL OPTIONS -- DATE -- CHOOSE mm/dd/yyyy FROM THE PULL DOWN



  • I like the bit just after "It's fairly self-explanatory", if they couldn't work that bit out I doubt they would of made it to step 8 in the first place...





  • actually I had a similar wtf myself ..

    see I work in montreal (we're bilingual so that means english and french) and I had to hack around a php application that creates a .csv file that could be imported into excel. problem is that some of the users have their locale settings in french, some in english. in english the field separator is a comma (hece comma-separated-variables) but in french it's a semi-colon. so some of the people wouldn't be able to open the .csv file properly ..

    the non-wtf fix is to check the browser's locale and separate your fields accordingly, the other way is to add another entry to the tech support faq that requires users to change their locale settings.



  • The Real WTF is that Outlook ought to let the user specify how to treat dates when importing csv. Or if it does, the site should say that. But I suppose MS have no interest in making it work well with csv, since that would improve interoperability, and help people break their lockin.



  • [quote user="rtaranu"]actually I had a similar wtf myself ..

    see I work in montreal (we're bilingual so that means english and french) and I had to hack around a php application that creates a .csv file that could be imported into excel. problem is that some of the users have their locale settings in french, some in english. in english the field separator is a comma (hece comma-separated-variables) but in french it's a semi-colon. so some of the people wouldn't be able to open the .csv file properly ..

    the non-wtf fix is to check the browser's locale and separate your fields accordingly, the other way is to add another entry to the tech support faq that requires users to change their locale settings.

    [/quote]

    The non-WTF "fix" is to generate a correctly formatted file, so it doesn't matter what locale it is.  Put quotes around any value containing a comma (or around all).

    Or just create a tab-delimitted file, and save a few hassles.

     



  • [quote user="Thanny"][quote user="rtaranu"]actually I had a similar wtf myself ..

    see I work in montreal (we're bilingual so that means english and french) and I had to hack around a php application that creates a .csv file that could be imported into excel. problem is that some of the users have their locale settings in french, some in english. in english the field separator is a comma (hece comma-separated-variables) but in french it's a semi-colon. so some of the people wouldn't be able to open the .csv file properly ..

    the non-wtf fix is to check the browser's locale and separate your fields accordingly, the other way is to add another entry to the tech support faq that requires users to change their locale settings.

    [/quote]

    The non-WTF "fix" is to generate a correctly formatted file, so it doesn't matter what locale it is.  Put quotes around any value containing a comma (or around all).

    Or just create a tab-delimitted file, and save a few hassles.

     

    [/quote]

    You don't understand, a comma-separated file, whether it's quoted or not, won't import into excel on a computer set to a french locale. (Without opening the file with custom csv options.) Semi-colons are the "magic" punctuation in french locale. I agree on the tabs though.



  • Excel is notorious for it's CSV file (non)support. Some years ago I was helping with IT as a summer job in a building company, and they asked me to find out why they can't import CSV files from some measuring instruments. Yup, Excel wanted semicolon-separated CSV files with comma used as a decimal separator, and the files were proper CSV with dot used as a decimal separator. Ended up writing a macro for importing the CSVs, since nothing else was feasible.



  • Excel's CSV importing? Bah, don't get me started on that!

    You can't properly import a .csv file manually, Excel just takes over and overrides a lot of your decisions. Rename the file .csvx and your options actually take effect. How damn stupid. Needless to say, most of my Excel data importing macros start with a rename file command just in order to get it to work properly.


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.