NCSoft Account Creation aka Wildstar Raid Attitude Test



  • I surfed around a bit and happened to read a bit about Wildstar. There was an ad about 7 days’ trial (and that failing some guest passes floating around the ‘net), so I thought I could give it a try. As I had played several of their games earlier (GuildWars, Aion, GW2) I had an account already at NCSoft.

    The login asked for my email or my account name. I checked which of my addresses had got email from NCSoft earlier, and submitted that, together with the password I suspected having used when I last played their games. The site indicated that the login information was wrong, so I tested an amount of other passwords, but with the same result. I then chose the “forgot my password” option and asked for a password reset. Nothing happened.

    “If you do not receive the email within 30 minutes, check your spam folders…” I waited for that, checked my spam, and tried to reset it again. Still nothing.

    I dug a bit more in my old emails and found an old password reset request with the account name. I tried logging in with the account name and the password - it was wrong. I tried a couple of other passwords and managed to get “Too many failed login attempts, login temporarily disabled. Please try again in a few minutes.” I hit the “forgot my password” -link again.

    This time I got the email. I followed the reset link, but as it had been ages that I had done anything with my account, there had been changes. The system asked me to provide the answer for a couple of random questions, check whether it should remember my location, choose a new Display Name and check that the game list was correct. This step took me again some ten fifteen minutes, because choosing names is a difficult thing… the Display Name was apparently not changeable, and that’s always stressful. The game list only had Guild Wars (Retail), though, together with a guest pass from 2009 - apparently Aion had been moved over elsewhere and GW2 account had autonomy. At last I hit okay and tried to log in.

    The login was still disabled. I waited for a few minutes, then a half an hour, but the error message didn’t change. The forum posts told me stories about people who had waited for an hour, three hours, and four days, without getting in. Apparently the error message actually was to be translated as “Your IP has been blocked. Change it or contact our support for de-blocking it.” I tried to resetting and renewing my IP, but my ISP kept giving me the same one. I hotspotted from my cell phone and managed to actually fill in the information…. damn, wrong password again. It must be the stress - I couldn’t even remember whether the earlier change had included the actual password change or not. I hit the “forgot my password” -link yet again.

    I changed the password and this time wrote it on a virtual paper, just to be sure. Yes, ths this time it logged in… for half a second - before kicking me out: “The game(s) associated with this NCSOFT Master Account are no longer available. If you migrated your account to an NC Account, please log in with your email address. Otherwise, you may create a new NC Account by clicking the button below.”

    Oh, drat. Ok, let’s see.. I tried to create a new account with the old information. Unsurprisingly enough, the email address - this time the only login name allowed - must be unique. Luckily I had an amount of game-related email addresses, so I chose the next best one. The next error message was: “There was an error creating your account. Please re-enter your account information.” After a bit of trial and error I figured that the Display Name wasn’t allowed as it was already “in use” - the one I had just spent 15 minutes choosing. I swore and took my second best choice - and changed the email address again, so that it wouldn’t resemble the second Display Name too closely. Still no luck - my password wasn’t good enough.

    The account creation site defined four rules for passwords: 1) 8-16 characters, 2) letters and at least one number or special character, 3) no more than 2 of the same character in a row, 4) must differ from the email address. The one I had chosen was - funny enough - the same password that had been accepted for my old NCSoft account, the one I wasn’t allowed to use anymore, and though relatively easy, met all the listed requirements, as well as some others. The help page explained that the system “rejects any passwords that are too easy or commonly compromised. You will need to try a different password until it is accepted.” Very helpful indeed, but I understand that they would want to weed out the qwert123’s and hunter22’s. Still, they could’ve updated the account creation page while updating the requirements..

    I ticked the “allow this IP” and “accept the terms”. Luckily the captcha is actually legible.

    I got my email verification email, clicked it and tried to log in. Bollocks, the login is still disabled. I fired up my hotspot again and logged in from my laptop. Unverified IP, right, I wait for the IP verification email to arrive and input the code. At last I’m in .. again. Now let me see…

    Add a game - Aion, Lineage II or GuildWars. No Wildstar. (The GuildWars is a small WTF as well, but I recall that the EU servers went over to ArenaNet or something, so this must still be the US version.) Heck.

    A friend mentioned that his old Wildstar Beta account had also same sort of autonomy than the GW2 account, only that the same master login information worked for him. So I went over to wildstar-online and tried logging from there. My old account auto-login got the “wrong login information” error, but when I stubbornly tried to enter the information again, I actually got in - to my new account, with which it didn’t share but the birth date!

    The whole thing did only take me three hours, which, coincidentally, is also the minimum length of an average guild raid.


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.