Xubuntu sofware update and proxies



  • My work computer does not have direct access to the Web; i have to use a proxy with NTLM authentication.
    Most Linux software do not work with that kind of proxy (Firefox does, but it’s deprecated since v30), so i had to install a proxy proxy locally on my machine. Then I set http_proxy=http://localhost:3128/ in /etc/environment and most software started working. So far, so bad.

    I have still trouble with the Ubuntu software update GUI, which completely ignores http_proxy. But I least I can take funny screenshots.


  • area_deu

    Xubuntu switches the updater's GUI to French when something fails?
    WTF.



  • I have exactly the same setup, with the exception my VMs are all openSuSE and the proxy settings configured in YaST Just Works™



  • @VinDuv said:

    My work computer does not have direct access to the Web; i have to use a proxy with NTLM authentication.Most Linux software do not work with that kind of proxy (Firefox does, but it’s deprecated since v30), so i had to install a proxy proxy locally on my machine. Then I set http_proxy=http://localhost:3128/ in /etc/environment and most software started working. So far, so bad.

    I have still trouble with the Ubuntu software update GUI, which completely ignores http_proxy. But I least I can take funny screenshots.

    APT {
      Acquire {
          http {
              Proxy "http://localhost:3128";
          };
      };
    };
    

    Shoving that into /etc/apt/apt.conf.d/01ubuntu (or into its own 01blah file under that folder, or whatever) should fix your proxy blues.

    P.S. the software update GUI likely ignores HTTP_PROXY because it's running elevated (sudoed), and elevated processes on *nix lose all environment variables that aren't set up to be kept in the /etc/sudoers file. It's a security thing in sudo; some environment variables (LD_PRELOAD, hello!) just aren't safe to pass to an elevated process, so it strips from the environment everything that isn't on its whitelist.



  • @aliceif said:

    Xubuntu switches the updater's GUI to French when something fails?WTF.

    No, his box is set for French, but the HTTP browser widget is returning an English error because it doesn't have a French version handy.



  • @tarunik said:

    Shoving that into /etc/apt/apt.conf.d/01ubuntu (or into its own 01blah file under that folder, or whatever) should fix your proxy blues.

    Actually, apt-get and friends already work fine, because i’ve added env_keep="http_proxy" in the sudoers file. It’s the updater GUI which has trouble. I’m pretty sure it is not launched as root.

    I‘ve tried to add the apt config file you suggested, but update-manager still chokes when downloading the package lists. I’m not sure how to get the “updates available dialog” back (it only popped up once when I logged in) but I don’t really think it would have helped.

    My main point wasn’t the proxy settings but the update notification window. I’m fine with it using a Web browser to fetch and display the release notes, but what about displaying a sensible error message like “Could not retrieve the release notes” when the retrieval fails?



  • @VinDuv said:

    Actually, apt-get and friends already work fine, because i’ve added env_keep="http_proxy" in the sudoers file. It’s the updater GUI which has trouble. I’m pretty sure it is not launched as root.

    I‘ve tried to add the apt config file you suggested, but update-manager still chokes when downloading the package lists. I’m not sure how to get the “updates available dialog” back (it only popped up once when I logged in) but I don’t really think it would have helped.


    Darn. Well, you can always do it manually with apt-get or aptitude every so often.
    @VinDuv said:
    My main point wasn’t the proxy settings but the update notification window. I’m fine with it using a Web browser to fetch and display the release notes, but what about displaying a sensible error message like “Could not retrieve the release notes” when the retrieval fails?

    Yeah, and a localized one too! My guess is that the widget it's using just lacks the facilities to tell its parent 'whoops, we can't do what we were asked to do'...(either that, or the parent is ignoring the widget's screams of anguish)



  • It's probably not respecting HTTP_PROXY because it's a Gnome app, and thus is looking in the registry Gconf for proxy information. Grep around in gconf-editor for the settings, or just use the Gnome control panel.



  • Because that would be a horrible error message. It would tell you nothing - the equivalent of 'something went wrong'.

    If a program does not know exactly what went wrong, it should spill its guts, dumping any errors given by the lower layers to the screen. Making errors look pretty is a silly idea.


  • Discourse touched me in a no-no place

    @robbak said:

    Making errors look pretty is a silly idea.

    You can give a drawing of a flower at the same time as the error details. That would let the error be pretty and informative at the same time.



  • @robbak said:

    If a program does not know exactly what went wrong, it should spill its guts, dumping any errors given by the lower layers to the screen. Making errors look pretty is a silly idea.

    *cough* those fucking Windows 8 bluescreens *cough*



  • @robbak said:

    Because that would be a horrible error message. It would tell you nothing - the equivalent of 'something went wrong'.

    If a program does not know exactly what went wrong, it should spill its guts, dumping any errors given by the lower layers to the screen. Making errors look pretty is a silly idea.

    Give a nice, non-technical error message, and a "More Info" facility that has all the guts hidden inside. That way, you don't have a pile of guts that confuses a non-technical user, but you still have the details where the techies can get them. (For logged errors, a dumpfile of some sort can be used in a similar fashion.)



  • Oh look, another case of Discoursistency.


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.