Cannot flag post with custom reason



  • I just tried to flag this post with the following custom reason:

    This man clearly deserves Trust Level 3

    However, when I clicked on the Private Message button, I got a dialog stating that an error had occured. What's up with that?


    No repro on Try, but consistent repro here.


  • Banned

    I cannot repro here, this is what I did

    • clicked flag
    • clicked "notify riking"
    • typed message
    • clicked Private Message button

    No error, but I am an admin, not sure if that matters. I could also suspect single sign on or account migration data errors?



  • Yeah, I'm thinking it's a database inconsistency - I cannot create any private messages.


  • Banned

    seeing a pile of

    "minimum must be non-negative" when checking topic title length in the logs. Looks like @PJH set validation minimums to negative numbers. Fixing the site settings now.

    But .... we really should get some validation in place for site settings. This is bad



  • But wouldn't some conventions make -1 == infinity? :-B So then nothing gets through! :smiling_imp:

    On the other hand, negative minimums isn't really error-worthy... It should have the same effect as 0, IMO.

    For the record, i can't repro either. Have just set a flag with custom message, and the post-action div even shows "You sent a private message to this user".


  • Banned

    That's because we removed the negative numbers in the settings that @pjh put there.



  • @c__ said:

    It should have the same effect as 0, IMO.

    The reason I tried negative numbers is because 0 didn't work.


  • Banned


Log in to reply
 

Looks like your connection to What the Daily WTF? was lost, please wait while we try to reconnect.